cPanel without stylesheet after enabling cloudflare


#1

I am unable to seen stylesheet of my cPanel dashboard after login and when I click at any link I redirect to again login page. this issue I am facing again and again since I unable to do anything with my cPanel even my phpdatabase link has been also disconnected… It’s all happed after my cloudflare activation.when I deleted the cloudflare then my website world good. Why I again this issue ? !
IMG_20180702_115849_110|690x478
I have been added like this dnd in my cloudflare dashboard big anyone know how I fix via add or remove any this option please have a look llbelow image and help to fix that problem.


I am new in dnd and Blah-Blah please help …


#2

See if it works if you set cpanel to :grey:.

Speaking of that, FTP also needs to be :grey:. This is because :orange: only proxies HTTP. Same goes for database connections. If your PHP database link is trying to connect to a :orange: host, it won’t work. You could use the IP address instead.

Mail is also going to be a problem if the MX record points to your :orange: server. Same reason: :orange: only proxies HTTP, not SMTP or IMAP.


#3

@sdayman Thank you 4 ur answer… but really I not understand what you want to say. please tell me what is required or update or delete. Pls


#4

In that Cloudflare DNS page, turn off :orange: for everything except www and shivkumar.in


#5

I watch the all various youtube videos there is says that enable all cloud in orange. But you says vice versa. Whatever. Tell me if I do behalf your command then all will be fine.?
am I able to login cpanel?
am I able to send email?
am I able receive email?
am I able to use SMTP? Or
all service generally we ise default.?

Yes or No ?


#6

Mail is not going to work if it’s hosted on your web server’s URL. MX should point to mail.shivkumar.in, and mail.shivkumar.in should not be a CNAME. It should be an A record set to 62.210.136.32 and set to :grey:

As for cpanel, it should work if it’s set to :grey:.


#7

This is I understand but please also tell what I add or remove for I want send email?


#8

Please read my post again. I explained how to properly set up MX.


#9

You means I add MX instead CNAME where is mail right? Then mail will also work. Am I right. If yes , then I can also delete MAIL CNAME ?