cPanel Plugin - SSL provisioning not working

cpanel

#1

Hi dear community,

we are a hosting provider and want to offer cloudflare over cpanel for our customers.

We have installed the plugin for cpanel and linked successful to our partner account. The CNAME setup is used. The redirection of the subdomains works perfectly.

However no ssl certificate can be issued. We have contacted cloudflare support with an affected account, and have received an api key which had to be added as CNAME in the customer DNS zone. Now it works.

Can the plugin query this api / CNAME record itself? Or must we open for each customer who wants ssl a ticket at cloudflare?

Thanks Stefan


#2

Hi Stefan,

The latest version of the cPanel plugin should take care of this automatically for you. Please make sure you are running the latest version. If that doesn’t work, it would be a good idea to email partnersupport[@]cloudflare[.]com and they can dig into it further.


#3

I have the same problem the cpanel plugin is not generating the CNAME for cloudflare to provision the ssl certificate, I am also running the latest plugin.

Regards


#4

Hi user5601,

my problem has not been solved yet.
Do you also use CloudLinux with CageFS?


#5

Do you have a ticket number I can reference?


#6

ticket number is 1422611. thanks


#7

It looks like the agent who was helping you is still trying to get to the bottom of this with our partners team. Stay tuned. Sorry for the delays.


#8

Hi ryan,

are there any news?


#9

Let me check on the ticket and see. Not sure what is going on with it.


#10

I’ll see if they can provide a more comprehensive update, but it looks like there were some dependencies that slowed it down and it should be done soon.