Cpanel dont work after activating Cloudflare

Hi,

After activating CloudFlare the Cpanel stopped working.
At first, I could not even log in (keeped logging for ever).
My hosting told me to add USA in the allowed country list and after that I can log in but the problem is that the CPANEL itself does not work properly (eg. images and icons are not loaded), and I can use anything such as file administrator, php config, etc.).

Is there anything I can do in the CloudFlare configuration?

My site runs under Wordpress and it’s www.estudiowls.com.ar

Thanks in advanced.

Is it just the cpanel URL or also the site itself?
The site itself loads and cpanel as well - sitemeer.com/#https://estudiowls.com.ar:2083

Which error do you exactly get? Can you post a screenshot?

Hi, thanks for your response!

It’s just the cpanel url /cpanel

Here is a capture

That screenshot does not exactly show an error and www.estudiowls.com.ar/cpanel actually does load fine and eventually loads the URL which I mentioned previously.

Or are you saying there’s an issue when you are logged in? Might be mixed content but close to impossible to say without being logged in. Maybe check out the browser console for errors.

2 Likes

Exactly, the issue is when i am looged in.

Once i log in, i cant do anything.

Then follow the steps I suggested.

Alternatively set up an unproxied host and point it to the right address, in that case Cloudflare won’t be involved.

1 Like

Cuold you please tell me how to do it?

Do what? Set up an unproxied record? Create a new record, name it “cpanel” and make sure it is :grey:.

1 Like

Great thanks

Cheking the DNS panel I see there is already a cpanel record A with the cloud in grey…

Should I do something else?

In that case you should use that hostname to connect. If that still does not work you need to contact your host, as Cloudflare is completely out of the picture.

These really are not Cloudflare issues but something will be off on your server-side. Additionally, make sure your encryption mode on Cloudflare is “Full strict”, that could also be partially the reason.

1 Like

After you switched to :grey: as @sandro suggested, have you tried to run an AutoSSL (for the needed hostnames) at your cPanel hosting?

  • if in case the mixed-content appears …

How can I do this? (In that case you should use that hostname to connect)
Please give an example, I have no clue…

Well, you set up that record, so now you just need to use it

cpanel.estudiowls.com.ar

That record is not using the proxies in any way, so if it still does not work you really need to contact your host I am afraid.

It worked!

Thanks a lot! (and for your patience)

It is solved thanks to @sandro

Thanks a lot

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.