Country, IP address, or ASN not recognized (revisited)

Firewall → tools gives an error (Country, IP address, or ASN not recognized) and does not accept input when entering an IP. No matter IP4 or IPv6 and format.


Thank you for asking.

I guess you are using IP Access Rules then :thinking:

If so, blocking countries using IP Access Rules is available only on the Enterprise plan.
As citeted from:

Block by country is only available on the Enterprise plan. Alternatively, Block by country is available on all plans using Firewall Rules.

Source article:

Nevertheless, creating a Firewall Rule by navigating to the Firewall → Firewall Rules → Create a Firewall Rule, you can select “Country” from a dropdown and then enter the one using “equal” or multiple “is in” → or for vice-versa “does not equal” or “is not in”.

Same applies for IPs, except the IP Access Rules accept only /24 and /16 mask when entering IP ranges for IPv4 and /64 for IPv6, while all the other can be used in Firewall Rules.

Furthermore, blocking IP/IP range/ASN can be done even on a Free plan.

After you have entered it into the “input field”, may I ask have you tried clicking on the small “pop-up” window to verify/confirm the entered value? :thinking:

Looks like this:

Helpful article:

Trust me this is a returning bug.

Can you share a screenshot of this error? :thinking:

Otherwise, may I ask have you tried using a different Web browser, or tried clearing your Web browser cache? How about using a Private window (Incognito mode) or a VPN connection if possible? Is it the same behaviour?

Nevertheless, kindly I’d suggest you to write a ticket to Cloudflare support due to your issue and share the ticket number here with us so we could escalate this issue:

  • Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button. If you get automatic reply, reply and indicate to it you need more help and reference to this topic
  • Or send an e-mail to support[at]cloudflare[dot]com from your e-mail associated with your Cloudflare account

I’m on a free plan. That means a ticket will get a response in about 7-14 days.
This is such an obvious problem, that it will be flagged in a few days.
Sorry if I seem pedantic, but this is about the third time in a few months this bug reoccurs.
It’s just a nuisance since I use it a lot.

I am really sorry to hear this :confused:

@alfa may I ask if this is possible related to your previous topics (and tickets too)? :thinking:

I believe together we can make it (as follows on my below cite:) to make sure it gets the appropriate attention.

Same prob, then it was a delay issue. Now it’s an error:

After inputting a valid IP:

That’s a bit odd. Even after you click on the “bubble” which appears under the input field upon entering it? :thinking:

1 Like

Right, when you click on the bubble it gets accepted. That’s new.

1 Like

Thanks, for the answer!

1 Like

Yep, seems so :wink:

I am happy to assist you :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.