Could someone tell me why my site is not showing as secure please?

Hi. I have set up a “full” SSL on

and set a rule to always use https

But it still isn’t secure. It’s really strange because it was secure for a few minutes and then not secure again.

Can anyone advise please? Thanks. Pat

You currently have a security issue.

Thanks. Any idea what the security issue might be? Are you saying I have been hacked?

Hi @pat6,

Is this the message you’re talking about?
image

No, but you might be. The linked article has everything on that.

Hi Albert. No. I’m getting he following message. And this has just changed a minute ago. Before this I was getting a general “unsafe, do not proceed” message…

And now my certificate is showing as valid. A minute ago it was showing as invalid. I don’t know what’s going on.

The “unsafe, do not proceed” message will only show if there’s issues validating the certificate used between your browser and Cloudflare. Not if there’s issues between Cloudflare and your origin.

You seemingly have a broken certificate on your server. You best pause Cloudflare for now, talk to your host to fix the server issue, and only unpause once everything is working.

Thanks. I’ve set it to full strict now.

1 Like

As mentioned, you need a valid certificate on your server. The article has all the details on that too.

That certificate is only valid for a subdomain, like www, or staging, etc. Hence the *.junction18studio
It should include the apex domain without a stardot in front.

Brilliant. I have it sorted now. Thanks a million.

1 Like

Thanks for your help. I got it sorted now.

2 Likes

Pleasure, how did you fix it?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.