Could not transform my website to https

Hello ! i’ve installed ssl on my wordpress and i have activated the option always use https but my website is still not secure !! any help please? thanks a lot

Could you post your website link?

forhelping.com

Can you help me please ? thanks a lot

Your website loads securely for me:

image

If it’s not https for you, you should clear your DNS cache, or try loading from something like a mobile phone.

i’ve opened it in so many browsers and its not secure !! wich browser did you use?

Try setting up the Cloudflare resolver on your machine, it should clear your DNS cache when you do this: https://1.1.1.1/dns/#setup-instructions