Could not find the worker when viewing or pushing error

Hey there,

I’ve been getting a weird error with one of my workers telling me it cannot find it (10007 error), even though it’s actively showing in the Dashboard (and it is mine).

I can make updates no problem (via the web UI), but keep getting that red bar every other second with the error: “We could not find that Workers Service on your account. (Code: 10007)”.

Pushing through Wrangler throws an error, saying it cannot find it, but have found that the code does actually update on the worker without issue.

Is there anything I can do to make that work again? Happy to give more details. The support “bot” told me to try here as it didn’t think it was related to the “Account”.

Appreciate any help.

– Vincent

Also want to clarify that other workers on my account do not have this issue.

I’m having the same error in one of my workers.

Might or might not be related:

  • I just upgraded to wrangler 2 in that worker. I still didn’t touch any other worker, so I don’t know if they’ll have the same issue if I do.
  • I get these warnings in wrangler console:
    • [WARNING] Queues are currently in Beta and are not supported in wrangler dev remote mode.
    • [WARNING] worker failed to prewarm: Service Temporarily Unavailable

Here’s a screenshot of what I get

More info - In the dev-tools network tab I see that every few seconds there’s a GET call to this url, that gets back 404:
https://dash.cloudflare.com/api/v4/accounts/<ACCOUNT_ID>/workers/deployments/by-script/<SCRIPT_ID>

UPDATE: I deleted the worker from the dashboard and redeployed from wrangler and it solved the problem. The side effect was that I had to recreate all secrets which was pretty annoying.

This has been impacting a few users every now and then, and the best current solution outside of contacting support, is to delete the worker and recreate it.

If you have submitted a support ticket for this issue, please provide it so we can track the impact here, along with your account ID and the script ID please.

Thanks for the reply. I haven’t yet heard back from my support ticket.

I’ll delete the worker for now. It runs a few on-the-side jobs, but I can move those to my own monolith.

I’ve had a reply from support on this issue, and they’re asking for a HAR file from the browser. No idea how that will solve the Wrangler API issue.

Long story short, I told them I will just delete the worker and use something else instead :v:

1 Like

That’s a disappointing support response, but understandable I guess. Can you provide the ticket ID just so I can add it to the list for tracking this issue over time?

It is what it is. Ticket ID: 2659675.

Thanks for the help here.

1 Like