Could not create my subdomain

Hi all,

I tried to create a subdomain for my main site but always got the DNS problem from Cloudflare.

I google the solutions and it has something to do with the adding the A record and or Cname record to my DNS at Cloudflare.

I followed the instruction and got the 404 error:

Are there anything wrong with my setup? Can anyone help me with it?

I struggled with this problem over a week now and it’s kind of frustrated.

You need to configure your server properly to respond to that hostname.

Hi sandro,

What do you mean by that?

I use BlueHost as my hosting and I did add my DNS from Blue Host to Cloudflare.

Assuming your server IP address ends in 117 it seems your server is not properly configured for HTTPS. You need to do this on your server side. It is best you pause Cloudflare for the time being, so that all requests go directly to your server, fix that on your server, and only once your site is working un-pause Cloudflare.

Pausing Cloudflare can be done on the Overview page at the bottom right.

Yes , my IP address really ends in 117.

I could pause Cloudflare and access to the server from my BlueHost account but I don’t know what should I fix in there.

Can you show me what should I fix?

Thanks so much

I am afraid server administration is far beyond the scope of the forum here. That is something you need to discuss with your host.

The main issue is the missing certificate on your server, that you need to fix. You can also use Cloudflare’s Origin certificates for that. The search has more on that.

So basically I should pause my Cloudflare nowand contact my host and ask them to reconfigure my server for HTTPS. And only after that, I can resume Cloudflare and my subdomain will work fine?

More or less. Once your site works fine on HTTPS, it will work in general.

Thank you! I will try that!

However I don’t have high hope for that really.

I contacted them before and they all saying that because my DNS point to Cloudflare, they told me to contact Cloudflare. And then when I contact Cloudflare technical support, no one reply. They just showed me a bunch of FAQ. Now I tried the community forum and I hope that I could fix this problem.

Well, they are your host, if they dont assist you in basic things like getting a certificate up and running it is best you change host. Cloudflare does not influence any of that.

Yes! I will try them one more time since I know what may be wrong now.

Thank you for the suggestion!

Hi sandro,

They fixed it and it really works this time!

Thank you so much for the suggestion!

Can you access it?

I can. It returns the content along with a 500 error, which shouldnt really happen, but the content is displayed. As for the 500 you need to contact your host or whomever maintains your site.

Oh my god! Another problem??

Guess I have to ask them again then.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.