Correct DNS for Cloudflare, but pointing to wrong IP

Hi!

I pointed my domain’s dns to Cloudflare, but when running the nslookup command, the returned IP is totally different from the IP that is configured in the Cloudflare panel.

What should I do? Help!!! :fearful:

Hi @daniel20,

This should help explain it:

1 Like

Hi, @domjh,

Thank’s!

If I turn off the proxy on the Cloudflare panel, the response from the nslookup command is responding at the correct IP. Great!

But if I try to access the site, it just doesn’t work. It is as if the domain does not exist.

This is the domain I am trying to access: pokerdepot.app

The domain simply doesn’t hit the server, even though the IP is correct (104.131.XX.XXXX)

What can I do?

Hello,

Your website loads if you type the IP address directly into the browser. It does not resolve however if you use www.pokerdepot.app or pokerdepot.app.

From what I see, you are missing an A record in your DNS or it is incorrect. It should look like this with your site’s IP address instead of the word Parked in the example below.

Log into your GoDaddy account and click on the Domain box to open Domain Settings.

Scroll down the page and on the right hand side there will be a link to Manage DNS. Click on that.

You will need to make sure you have an A record with your IP and it is correct. If there is no A record similar to the above, then you will need to click the ADD text at the bottom of the list and ADD the A record.

Once you do that, your site should start resolving.

Once the site is working, then you will want to make sure all of the DNS records in GoDaddy match the ones in the DNS section in Cloudflare. Leave all the GoDaddy records alone. DO NOT DELETE THEM.

After you have verified everything matches, then it is time to change nameservers.

Your domain is currently showing that your domains nameservers are still GoDaddy nameservers

`Nameserver records returned by the parent servers are:

ns27.domaincontrol.com. [‘97.74.103.14’] (NO GLUE) [TTL=10800]
ns28.domaincontrol.com. [‘173.201.71.14’] (NO GLUE) [TTL=10800]`

You need to change your name servers at GoDaddy to Cloudflare’s name servers.

When you added your domain to Cloudflare, it should have scanned and copied all of your DNS records from GoDaddy and then you verified them as I mentioned above. Below your DNS records in Cloudflare, you should see the two name servers you need to change your domain’s namesevers to in order to use Cloudflare. For example mine are, yours may be different:

Log back into your GoDaddy account and click on the Domain box again to open Domain Settings.

Scroll down the page and on the right hand side there will be a link to Manage DNS. Click on that again.

DNS Management will open up. Scroll down below all the Records to Nameservers. Click on the CHANGE button.

It will then open up Choose your nameservers.

Click the radio button to I’ll use my own namerservers.

image

Enter your Cloudflare nameservers in the boxes and click the Save button.

image

Now your site should seamlessly switch all traffic over to going through Cloudflare over the next 48 to 72 hours.

You should get an email once Cloudflare verifies that the new nameservers are in place and the site is working properly.

You can also watch you Cloudflare control panel and it will also let you know when the transfer has occurred.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.