Correct DNS Configuration (cname forwarding)

I use a landing page service, wishpond, where I create landing pages and I use my domian name as the publish location. All they ask is to forward the domain name to them through the DNS settings. Basically a CNAME record of “www” forwarding to “tls.wishpond.com”. The issue I have is that while my domain name works at www.unidosati.com if I first type in the domain name without the www, it won’t work and will only show an error message. If I first visit the page with the www, then the browser makes it work even if i type it in without the www.

BASICALLY, how should I configure my DNS to forward both “www” and non www entries forwarded to the same place?

Thanks so much for the help!!

That is slightly odd, as it should either work or not and that is something that is related to your hosting and not Cloudflare.

However, if you want to force the www record, you could have a look at Redirect example.com to www.example.com

You do not seem to have a record for your naked domain however. That would be necessary in any case.

1 Like

Thanks so much for this! It worked perfectly. Since I have the domain “hosted” on this external service the A record didn’t really work for me, but setting the dummy A record and using Cloudflare’s Page Forwarding solved this perfectly! Thanks again!!