ContactPoints.io works on desktop, but not mobile

I host my website on godaddy, with cloudflare nameserves. GoDaddy is registrar.

If I type contactpoints.io on desktop, it works.
If it type contactpoints.io on mobile browser, it’s always a connection timed out.

How to fix this?

Thank you!

Correction: hosted on heroku!

Is there anyone here?

Turns out Heroku says there is no SNI endpoint. Heroku told me I have to fix this on Heroku. I don’t know how to do this.

When I type: heroku domains, I see this:

contactpoints.io ALIAS or ANAME spherical-island-*.herokudns.com undefined
www.contactpoints.io CNAME quiet-badlands-
.herokudns.com diplodocus-31145

Heroku says that the reason contactpoints.io is listed as undefined, it’s because the SNI endpoint is not set up.

I do not know how to set this up on Cloudflare to make this work.

Can someone kindly assist?

You will want to ask Heroku how to configure their platform. The Cloudflare Community is not going to be able to answer your Heroku questions.

The message that you posted in your duplicate topic (which I have merged here) better describes your issue.

You appear to be having trouble reaching your site without www. You may want to simply redirect your apex name to the www using Cloudflare. The following Community Tutorial will show you how.

But I don’t know why this even needs to be done.

I have another site that has the same settings (heroku/cloudflare/ and everything looks the same). That other site works fine with both www and without, and there is an SNI endpoint.

Heroku said absolutely everything is set up correctly on Heroku, and that the problem 100% is with the settings I have on cloudflare.

But the settings on cloudflare for both sites are identical. So I don’t know why there is a need for any redirects. Cloudflare should be properly sending the correct SNI endpoint to Heroku…

That all being said, thank you @epic.network because what you suggested above did in fact work. So much appreciated.

However, I still don’t know why I had to do that with this site, but not the other… Got any thoughts?

I am glad to hear that redirect is working.

I don’t know why Heroku doesn’t receive the SNI name that it needs. I have sites in Cloudflare that use the apex name as the canonical name and they work fine. None are one Heroku, though.

Hopefully the redirect is an acceptable solution.