Contact Form 7 not sending out content anymore

We have a Contact Form on our wordpress site which has worked fine in conjunction with Cloudflare for years but stopped sending out the forms to our email at the end of last week. Users can still submit their info and it is still showing in the Contact Form DB on the backend but won’t now send to our gmail.

This is a known issue:

So we have followed this advice and configured our Email Routing to Remote Mail Exchange in our cpanel with the company that the site is hosted with. The seems to be the correct fix but 12 hours later, the form still isn’t sending out the emails. Since the site uses Cloudflare do I need to purge a cache somewhere in here to force through the change to the mail exchange? Or maybe even add a new DNS MX record to make the change in Cloudflare rather than in the cpanel?

Or going further do we need to submit a flush MX cache request to google using this:

Adding our domain in and ‘MX’ into the RR type?

Any help really appreciated. We can’t understand why this worked with no problem, then just stopped.

Doesn’t CF7 have a Send Test option? It it showing an error? Or is mail just not showing up?

You may want to give a try to track this down.

This topic was automatically closed after 31 days. New replies are no longer allowed.