Constant ERR SSL VERSION OR CIPHER MISMATCH error

Hello,
I’ve been trying to setup an SSL certificate on my apache2 website and I’m constantly getting ERR_SSL_VERSION_OR_CIPHER_MISMATCH.
My apache2 config is:

<VirtualHost *:443>

ServerAdmin [email protected](dot)com
ServerName website(dot)com
ServerAlias www.website(dot)com
DocumentRoot /var/www/wordpress/
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

RewriteEngine on
RewriteCond %{SERVER_NAME} =website(dot)com [OR]
RewriteCond %{SERVER_NAME} =www.website(dot)com
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

SSLEngine on
SSLCertificateFile /etc/cloudflare/website.com.pem
SSLCertificateKeyFile /etc/cloudflare/website.com.key
SSLCertificateChainFile /etc/cloudflare/origin_ca_rsa_root.pem

I have also used openssl to verifiy that my pem files are correct.
I have enabled the ssl mod on apache2 as well as allowed port 443.
I seriously cannot figure out what I’ve done incorrectly. Any ideas?

If the site is :orange: Proxied by Cloudflare, then the Cloudflare certificate is the issue.

Can you make sure that Universal SSL is enabled for your zone?

Check your Cloudflare Dashboard - SSL/TLS > Edge Certificates > Scroll to bottom > Disable/Enable Universal SSL

I can’t believe I had this disabled. Now unfortunately I have a too many redirects error. But it did fix the certificate error.

1 Like

First thing to check is that your SSL/TLS mode is Full (Strict), if it is, check the other suggestions here:

1 Like

Actually, just found out that it was a redirect in my apache site config. Everything works now! Thank you!

2 Likes

woohooo :tada:

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.