Connection to R2 bucket via Cyberduck fails

Hi!

I used to connect to my R2 bucket via Cyberduck to upload larger files.
However since roughly 2 weeks this always fails with the following error message:

“DNS lookup for XXXXX failed. DNS is the network service that translates a server name to its internet address. this error is most often caused by having no connection to the internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing access to the network.”

I have this problem from several PCs and my internet connection is definitely available.
So i have 2 question:

  1. How can I fix this issue? Unfortunately I am by far no professional in this field, so a dummy-proof answer would be very much appreciated :wink:
  2. Is there any online service I can use to load larger files to the R2 bucket as a fallback option?

Thank you so much for your help!

I had a simmilar issue with Cyberduck, it was because the URL provided in bucket settings contains “https://” prefix as well as the name of the bucket at its end.

What you want is an url like this: .r2.cloudflarestorage.com and make sure that the connection type is set to Amazon S3.

The login credentials for your bucket you can find on the right hand side bar of the R2 overview page under “manage API Token” or something along those lines.

Hope this resolves your issue.

1 Like