Connection timed out Error code 522 - (Github, Pages, Custom Domain)

I’m aware that this topic has been posted several times on this board already, but I’ve been stuck for hours and couldn’t find any solution to my problem. The site was working just fine previously, I mean it’s accessible from my browser, but today I had connection timed out - error code 522, but couldn’t remember what had I done previously that created the situation, here are the details:

  • Using Jekyll as my SSG, and have them hosted at GitHub.
  • Connected and deployed them on and they worked like charm, without the custom domain.
  • Change the DNS of the custom domain to point to Cloudflare’s DNS server.
  • Had a CNAME registered for www records that points to the deployed pages.
  • Previously, they worked out just fine, but now I’m getting 522?

But the funny part is that, I had several other domains with the similar setup (only different SSG), with similar method that worked out just fine, up till now.

Any ideas what’s wrong with my current environment setup?


Do you have the custom domain added in the Pages section of the dashboard?

My bad, as it turned out, I haven’t finished setting them up in the dashboard section of the domain. Thanks @domjh


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.