Connecting with FTP


#1

I’ve recently set up cloudflare to protect my site so it uses https. it all works fine, the only issue I’m having is connecting via FTP, when i make changes to my site.

I’ve tried to suggestions on the support page and neither option helped. when I asked my hosting company they said cloudflare would have set up DNS sub-domains one of which points back to my hosting server, i I should use that hostname to connect the server rather than how i did originally.

I’m either doing this wrong or it doesn’t work either. can anyone help or have and idea what to do?

Thanks

Rob


#2

Hi @rob2,

Please click the orange cloud next to the entry to turn it gray, this will allow traffic to go direct to origin (we don’t proxy FTP traffic today).


#3

I’ve tried that and it still won’t work, I also tried to copy the IP address it points to and that worked at first but then quickly stopped.

[removed by staff to protect origin IPs]

Im assuming you mean the middle one in the image here, marked FTP.

thanks


#4

Yes, that was the one I was referencing (I peeked at your account)…

Try creating a record called totallyNotFTP (no one will ever guess that host name) with the same IP address and set it to gray from the beginning to see fi that works. You may somehow have cached the orange clouded record. I just connected to the source IP and it does answer on the right port so should work.

The other option is to connect to the IP directly.


#5

thats great thanks, seems to be working now. cheers