Connecting to email account issues

Hello,
I have been all over the forum, hoping I didn’t miss it but we will see.

Recently, I wanted to test out cloudflare ( yes I am new ) and I seem to have got the configurations right. The problem is there is no access to my email accounts. Can’t log into them to check my email. Never had this problem and godaddy won’t support as we are on CF now. Thoughts ?

Also, wanted to ask this - everything is controlled by cloudflare so should I delete all the DNS in my WHM for the domain. Thanks!!!

The consistent message here is that any mail-related hostnames have to be set to :grey: DNS Only. Your ‘mail’ CNAME points to a hostname that’s set to :orange: Proxied.

Try deleting that ‘mail’ CNAME and make it an “A” record like all the rest. But set to :grey: DNS Only.
And your MX record for your domain should point to your ‘mail’ subdomain.

1 Like

Thanks for the quick reply … I have never in all my years points MX to mail.domain.com is that just a thing for CF ?

You don’t look that old in your avatar picture.

It’s not just a CF thing. And it’s quite standard in the corporate world. Servers are somewhat dedicated and don’t run multiple services on the same machine. At least in those environments. Heck, even the database gets its own server(s).

Anyhow, it’s even more important in the CF environment to separate out hostnames for services. Much like you already did for FTP (which also should be :grey: because Cloudflare doesn’t proxy FTP). But in CF’s case, :orange: is for proxying HTTP/S. Nothing else, unless you’re using Spectrum.

1 Like

Still not able to connect to my email …

May I ask via your e-mail client like Mozilla Thunderbird, MS Outlook, etc.?

  • maybe you are missing autodiscover and autoconfig DNS hostnames/records, just in case of MS Outlook, if so … (you could try to re-add them)

Have you checked if your POP3/IMAP and SMTP server is set to mail.easycrypto.club?
Also, have you used SSL too?

Reverse PTR is:

9.132.204.92.in-addr.arpa ->  mainnet.itsmunkey.com
mail.easycrypto.club   92.204.132.9

Seems to me, different domain and hopefully having the correct SSL certificate (just to make sure you are using secure connection), that could pass (I see the SPF and DKIM records), or actually not?

  • correct as far as the DNS entries added in the SSL certificate (despite the fact of different CN value)

Looks fine by testing so far:

Or, wait for some time to apply the changes, due to the recent DNS changes which could possibly be cached at your home router or local ISP.

Have you tried using https://www.mail-tester.com/?

1 Like

Is the server - the a dedicated server with godaddy and easycrypto.club which is just a domain I am test cloudflare on is an account on there.

I am using Apple Mail.

1 Like

Your server responds to POP mail. I didn’t test all protocols and ports, as just one is a good indicator. Just make sure your mail apps are set to use the ‘mail’ hostname.

1 Like

Screen Shot 2021-08-31 at 7.23.04 PM

I have 25 accounts and they are all connected without a problem. The single account that is CF is the only one with an issue. IMAP and I am over here pulling my hair out. Lol.

Oh, and you mentioned that the pic didn’t look old- I am pushing 40 brother - good genes ROTFL!!

It could just be that the DNS update still hasn’t made it to your device.

Do you access that same mail account on a mobile device mail app? You might try that, even over cellular so you’re on a different network.

2 Likes

It’s a strange one, and maybe that is the problem. Ran into this with my other domain and gave up, so started this one as a test to see if I could get it all working. Lol, trying to learn this stuff but at the same time feeling like I don’t know a dam thing lol

Well, as we say “step-by-step”, with learning, even with troubleshooting (that’s the best way to learn - either to lose some time just to figure out where the real issue actually is) :wink:

1 Like

@sdayman Everything is controlled by CF right so nothing should ever be updated or change in my WHM. This is what I have always thought, just want some form of confirmation and I appreciate all the help on here thus far.

1 Like

Good point. Since the ‘mail’ hostname is new, you might need to make sure that’s added to the system there and that it has SSL enabled. I know in cPanel there’s an AutoSSL process that would take care of this.

1 Like

This is what was there … I am able to send and receive email by checking it via the roundcube panel.

Roundcube is probably connecting internally to easycrypto.club.

That screenshot looks like local DNS, and it looks like your earlier setup that you had to update. You may have to repeat those steps at WHM as well, but there should be something in that panel that will let you configure SSL for the various hostnames.

1 Like

If I may add a note here, what I see from the provided screenshot, the TTL value is set to 14400 (as already stated from the previous replies, there could be some DNS cache).

Next thing, from my past experience, when using Cloudflare for any domain which is on cPanel hosting, usually I remove the CNAME records on the cPanel DNS Zone Editor side and make sure I add A mail and A www records pointed to the IP address.
Therefore, altering (modifying) the MX record (again, at the cPanel DNS Zone Editor side) to point to mail.mydomain.com - just in case.

I am actually not 100% sure if this could change anything as far as for some domains recently I haven’t done this procedure at the cPanel side, while the e-mail continued to work propperly.

Just in case, can you make - if already not - on the DNS tab at Cloudflare dashboard, the CNAME www - remove it, and add an A www which points to the IP address (also being :orange:)?

Have you tested, does receiving/sending working through the Roundcube Webmail of the cPanel interface?

1 Like

I see mail.easycrypto.club is in a DNS entry as Subject Alternative Names (SAN) of the SSL certificate already, while the SSL is a valid one.

1 Like

Here is everything change at the moment.


I finally broke down and tried MXToolbox for this.

While the web server may have the cert(s), the mail server might not, such as this:

1 Like