Connected and using DoH , but as name is not cloudflare

https://1.1.1.1/help#eyJpc0NmIjoiWWVzIiwiaXNEb3QiOiJObyIsImlzRG9oIjoiWWVzIiwicmVzb2x2ZXJJcC0xLjEuMS4xIjoiWWVzIiwicmVzb2x2ZXJJcC0xLjAuMC4xIjoiWWVzIiwicmVzb2x2ZXJJcC0yNjA2OjQ3MDA6NDcwMDo6MTExMSI6Ik5vIiwicmVzb2x2ZXJJcC0yNjA2OjQ3MDA6NDcwMDo6MTAwMSI6Ik5vIiwiZGF0YWNlbnRlckxvY2F0aW9uIjoiSEtHIiwiaXNXYXJwIjoiTm8iLCJpc3BOYW1lIjoiTmV0dmlnYXRvciIsImlzcEFzbiI6IjQ3NjAifQ==

I want to know am i really using 1111 as my DNS. And if not, any possible solution to it?
Thanks for your help!

I think this is indicative of a DNS leak or transparent dns proxy (although forcing DOH should mean this isn’t possible without errors) - can you see if your ISP shows up in a leak test @ https://www.dnsleaktest.com/ ? Also, how did you enable Dns Over HTTPS (Chrome, Windows, 1.1.1.1 app, etc)?

By performing a standard test at the dnsleaktest site, both cloudflare and my ISP shows up.

The DoH service is running on my raspberry pi with cloudflared GitHub - cloudflare/cloudflared: Argo Tunnel client

Thanks!