Connect from tokyo ok , but connect from Los Angeles fail

dash-dns
dash-crypto
#1

Hi
My site https://minerooms.com , use cloudflare for CND
customer connect from tokyo is ok , but from Los Angeles get 520 error
how can i fix that?

#2

For starters, your domain does not have a www record. No idea if this is intentional.

Second, your domain only works on HTTP (presumably because of the automatic Cloudflare rewrite) but not on HTTPS -> http://sitemeer.com/#https://minerooms.com

The way it seems I would say your server simply is not responding. You need to clarify this with your host.

#3

Hi
thank for reply
if i close CDN , customer can connect directly , but when i open CDN can’t connect

Ray ID : 4cfa97a97dd399b9

#4

What do you mean by close?

Would you feel comfortable to share your server IP address here?

#5

close mean change ‘DNS and HTTP proxy’ to ‘DNS only’
my ip : *

#6

All right, you can delete the posting with the IP now (if you want to keep the address hidden).

The problem would seem that your server is not configured for HTTPS. You need to make sure it is listening on port 443 and has a proper certificate installed.

1 Like
#7

I use page rules for workaround (https -> http),
it was worked for long time , but not today?

#8

So you do not want HTTPS for your domain? The first link you posted was an HTTPS one actually.

#9

Yes , for now , workaround is good for me :smile:

#10

In that case you dont need a page rule. Just switch the SSL mode on the Crypto page to “Off”. This will automatically redirect HTTPS to HTTP, already on the side of Cloudflare without any page rules.

#11

my Crypto is setting ‘flexible’
I don’t change any config , but web side cant connect , why?

#12

It should never be Flexible. That is a bad choice per se.

If you dont want HTTPS switch it to Off, otherwise switch it to Full strict and configure your server properly for SSL.

#13

That strange
same config was work long time :disappointed_relieved:

#14

I cant suggest anything else than what I already suggest. Is HTTPS important to you or not? If not switch to “Off” and Cloudflare will take care of that redirect.

#15

ok
switch to ‘off’ and Automatic HTTPS Rewrites switch to ‘off’
need some time for apply?

#16

It now seems to load fine http://sitemeer.com/#minerooms.com

#17

No , when i login with Facebook ,
i get 520 again

#18

Log in where? The site itself loads fine.

#19

http://minerooms.com/users/sign_in

sign in with facebook

#20

That’s an issue with your application giving an error. Check your server’s error logs, or ask you host for the error logs.