Confused why my Cloudflare Pages website is not working (404 error)?

Here are all my DNS settings.

Does it have an index.html file in the root directory?

Can you tell me how to find that out? Sorry.

At this point, the better question would be “Why should it work?”

What did you upload that makes you think there should be a website there?

I did just find the index.html is there:

That’s not in the rood directory.

Since you shared the structure, I can see it loads here:
https://phront.org/public/

But not that well, since the contents of Public should have been installed at root.

Try gzipping just the public folder, and upload that instead. I think it’ll extract it into the root directory. (I could be wrong, though. It’s been while since I’ve tried)

I did as you said. I do not think that worked. So this must be an issue with what I am uploading? I don’t understand why the phront.org/public works though. Thank you for your help with this.

Ok, it looks like it works if you just upload the folder:

I am very happy that at least phront.org/public works - so is the issue essentially that I am uploading something non-functional?