Confused... DNS records.. proxied / DNS?

I have been using cloudflare for a while now… So i thought…

But i don’t think i am actually using Cloudflare service…

All my DNS settings are Grey clouds. except for 3 CNAME Accounts… is that right? I feel like nothing on my site is being proxied and i also don’t think it is serving SSL from Cloudflare…

I think everything is DNS

BUT i remember from past when i have changed everything to Proxied then i don’t get any emails…

Am i doing something wrong? is there anyone who can advise… this may seem very straight forward to some but i actually think i am just passing all traffic through Cloudflare BUT not using the actual service… can this be the case?

I have all these DNS records BUT the only ones with a orange cloud are the Name ones…

I also went to https://checkforcloudflare.selesti.com and it gave me the following information:

my URL is using Cloudflare DNS!
is NOT using Cloudflare CDN/Proxy
is NOT using Cloudflare SSL

So what am i doing so wrong? arghhh totally feeling dumb…

Can you share the name of the domain?

Sharing as a image as prefer it not to show up in search results… (maybe it wouldn’t)…

Thanks

1 Like

This is consistent with what you describe. You website is DNS-Only. No Cloudflare CDN, no Cloudflare SSL.

As for the email issue, here’s why:

So you MUST have a MX record for it to work?

I have DNS records for mail - just no MX ones

So i added 2 MX reccords for Mail.myurl.com and also webmail.myurl.com

Now to turn it to Proxied which A records do i turn to orange cloud?

would it be all 4 i have set up? * / www / server & myurl.com? or would i also add the A records for mail and webmail as proxied since i now have MX records?

Thankyour in advance

and when i add the MX records and turn all A records to proxied - i get orange ! next to the MX records!! so guessing it doesn’t work like that

To receive email, you need an MX record. It should only point to mail.example.com. And mail.example.com should be set to :grey:. Everything else can be set to :orange:.

You’ll get that ! as a reminder that email doesn’t hide your website’s IP address. That’s normal when you host email and a website on the same server.

ok so this kind of looks ok?

That very first “A” record, ‘mail’ needs to be set to :grey:.

You only need one MX record. The middle one for ‘mail’ with a 1 after it (not the 100).

CDN and SSL now working on Cloudflare but emails not working again… with above settings

new records after your suggestion - the ! next to the first A is ok is it?

That’s all you need. As long as your mail app uses ‘mail.example.com’ for sending and receiving email, you’re all set.

See when i set up my emails on my iPhone for example i put in the server as just example.com not with the mail bit NOT: mail.example.com

could that be the reason?

does that make any difference? lol

Seems like i can either have CDN & SSL or Email… hmmmmmm any further suggestions?

Sorted… thanks for the help :slight_smile:

2 Likes

This post was flagged by the community and is temporarily hidden.