Conflict with Ezoic and CF cache because CF cache is set to dynamic

Hello guys,

I have many MISS-es related to caching. My website is integrated to Ezoic via CF.

Here’s what the support told me:

"I’ve been reviewing your gtmetrix test and I can see you have resources that should be cached that are not being cached. For example:

damian$ cu-I ‘ZWlnaHQiLCJ2YWwiOiI4NjMifV19LHsidHlwZSI6InBhZ2V2aWV3IiwicGFnZXZpZXdfaWQiOiJlYTQyYzQxYi0xZTc1LTRiY2ItN2I1My1hYzdjNDNkNWIyNjYiLCJkb21haW5faWQiOiIxMzcyOTMiLCJ0X2Vwb2NoIjoxNTg1NzQ2NjU2LCJkYXRhIjpbeyJuYW1lIjoidF9sb2NhbF9kYXRlIiwidmFsIjoiMjAyMC0wNC0wMSJ9LHsibmFtZSI6InRfbG9jYWxfaG91ciIsInZhbCI6IjYifSx7Im5hbWUiOiJ0X2xvY2FsX2RheV9vZl93ZWVrIiwidmFsIjoiMyJ9LHsibmFtZSI6InRfbG9jYWxfdGltZXpvbmUiLCJ2YWwiOiI0MjAifV19LHsidHlwZSI6InBhZ2V2aWV3IiwicGFnZXZpZXdfaWQiOiJlYTQyYzQxYi0xZTc1LTRiY2ItN2I1My1hYzdjNDNkNWIyNjYiLCJkb21haW5faWQiOiIxMzcyOTMiLCJ0X2Vwb2NoIjoxNTg1NzQ2NjU2LCJkYXRhIjpbeyJuYW1lIjoibGFuZ3VhZ2VfdGFnIiwidmFsIjoiZW4tVVMifV19LHsidHlwZSI6InBhZ2V2aWV3IiwicGFnZXZpZXdfaWQiOiJlYTQyYzQxYi0xZTc1LTRiY2ItN2I1My1hYzdjNDNkNWIyNjYiLCJkb21haW5faWQiOiIxMzcyOTMiLCJ0X2Vwb2NoIjoxNTg1NzQ2NjU2LCJkYXRhIjpbeyJuYW1lIjoibGFuZ3VhZ2VfcHJpbWFyeV9zdWJ0YWciLCJ2YWwiOiJlbiJ9XX1d’
HTTP/2 200
date: Fri, 24 Apr 2020 20:19:00 GMT
content-type: image/gif
content-length: 43
set-cookie: __cfduid=d8e1469e9991ff3e4ddf9eb8b5608283e1587759539; expires=Sun, 24-May-20 20:18:59 GMT; path=/; ; HttpOnly; SameSite=Lax
cache-control: max-age=0, must-revalidate, no-cache, no-store
expires: Thu, 23 Apr 2020 20:18:59 UTC
vary: Accept-Encoding
vary: Accept-Encoding
vary: Accept-Encoding
x-middleton-display: ezp_sol
cf-cache-status: BYPASS
accept-ranges: bytes
expect-ct: max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct
server: cloudflare
cf-ray: 589284401b0bf417-LHR
cf-request-id: 024f70fc120000f417aebda200000001
As you can see the cf-cache-status response header returns a contant BYPASS meaning its never served from cache.

The reason this is occurring is because your origin hosting provider is setting

‘cache-control: max-age=0, must-revalidate, no-cache, no-store’

The max-age=0, no-cache, no-store are preventing Cloudflare from caching the images.

I would reach out to your host, which looks to be ezoic to get this corrected."

So I contacted Ezoic and they explained that the problem comes form the fact that the caching at CF is dynamic and it should be set to Standard or Aggressive.:

" If you are using Cloudflare you will need to make sure this is set to “standard” or “aggressive” to be compatible with Ezoic’s cache.

We can see using the redirect path that the CloudFlare caching is set to “Dynamic”, which often caches in front of Ezoic and can cause errors.

This includes massive cache ‘misses’ by the Ezoic caching app (see below)

k-hcAjIZ766rftX3oXjMRp_q_WEMOHFV1F7JUZZT2fndwtcPkh1lxxpTmR2v5hQDIEuZFx9TsosXbVzuME6tqzwREEAK4akyH07QCMQtWF1j_q-9PvjnNO9YIONU9_iv1wvoNx5r8GpJp_WHwaWvWcCwXiKfRuHdwnIDmLzUUjUjnsodWl2b86wZFeWD4u1Izt-QhzTIiwVSXReu-7AB_9HrLG=s0-d-e1-ft#https://attachment.freshdesk.com/inline/attachment?token=eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJpZCI6NDgwMzc1MDYxOTgsImRvbWFpbiI6ImV6b2ljLmZyZXNoZGVzay5jb20iLCJhY2NvdW50X2lkIjoxMTU4NjQzfQ.emr-fd1OFR-ZXcH_8xXtfdfL-oFQgppElijI-g8XyQM)

You will need to update the CloudFlare caching settings to either ‘Standard’ or ‘Aggressive’ in order to continue using both the Ezoic and CF Caching.

"

When I go to the “Caching” section of my CF account I see that the Caching level is set to Standard.

Is there any other setting I have to update?

Thank you in advance!

This topic was automatically closed after 30 days. New replies are no longer allowed.