Confirming how to add DNS record for subdomain

I’ve reopened this for adamabrams on their request because the topic was automatically closed while they were waiting out the posting limit.

1 Like

Thanks @lindseym for reopening this!

Hey @sandro, turns out I was slapped with a limit on how many replies I could make on my first day as a new user of the forum! (On top of a 2-links-per-post limit!) It said I must to wait 23 hours to post again but then the thread was auto-closed after 24 hours. Ouch!

Anyway, yes I noticed the “www”… thought that would be trouble. I’m working on that issue currently.

Since posting last, I added the one A record for “staging3”, pointing to 35.209.4.246 . Still having connectivity issue but I’ll take it up with the hosting company at this point.

Just to wrap up and clear my one remaining point of confusion: I don’t understand how staging3.room920.com is not a “subdomain” of room920.com . A “regular hostname” would be “staging3.com”, yes? Just want to make sure I have my terminology straight.

Anyway, the main thing I wanted to say was, thanks SO much for your help!

You do have a record for “www.staging3” now but there still is none for “staging3” itself.

Technically it’s a label, but for it to be a sub-domain, it actually needs to be a domain which has its own NS records and zone configuration. Just like room920 is a sub-domain of com.

It would be a hostname if it was e.g. an A record in the nameservers of the .com registry. In your case it is a proper sub-domain with NS records.

Fully agree, terminology is way too often neglected or misused (best example, bandwidth and traffic) :slight_smile:

My pleasure :slight_smile:

My confusion just came from not knowing if you wanted to delegate a proper sub-domain or just set up a record for a hostname.

Hi again!

Well, 24 hours after creating an A record for just “staging3”, the domain still was not resolving - and I saw that all links to it from the hosting panel were attempting to go to www.staging3.room920.com . So I changed the A record to refer to www.room920. But it’s still not working.

But I don’t need to do any of that in this case, yes?

I also spoke to hosting support and they said the A record was all I needed, and the www was not necessary to add.

So I"m still spinning my wheels here, no idea what to try next other than the following:

  • I’ve reverted the A record to “staging3” (dropped the www)
  • I’ve changed the Proxy Status to DNS Only

I’ll wait and see if this makes a difference, but other than that I’m stumped.

Can we for starters verify the nameservers which Cloudflare provided for your domain on your account? To make sure we are on the right account. Which nameservers do you have there?

Presumably not. It really comes down to what you want, but from your description an A record should do.

Yep, those are correct:

brynne.ns.cloudflare.com
mack.ns.cloudflare.com

They’re set that way at GoDaddy. And the main site (plus presumably everything else) is working fine.

In that case the nameservers are correct and the next step would be to verify the DNS records.

Can you post a screenshot of the relevant records?

Sure, here you go!

You changed the record, right? You now have the right record in place but your server sends a redirect to its “www” version. Either remove that redirect or set up that record, but then you will also need a paid proxy certificate.

In any case, you also need to fix your server certificate as that is invalid right now as well.

Hmm. I can ask the host to set it so it doesn’t do that www redirect.

But a paid certificate is not an option and hopefully not needed… I see the certificate for room920.com is valid, why would it not work for the subdomain? How do I fix that?

If you want “www.staging” it will be. There’s an article under #tutorials explaining that.

But still, you need to fix your server certificate too, right now you will have an insecure encryption mode on Cloudflare.

I’ll have a look, thanks! But meanwhile I’ll see about getting the “www” removed at the hosting end of things.

Do you mean it’s insecure for the purposes of the staging site? I’m just unclear on what the issue is and how/where I can see it… and what to tell Cloudflare support when I talk to them. (Since it appears fine on the main site as per my screenshot). Thanks!

For the purpose of a staging site it might not be insecure, respectively in that context a broken certificate might be acceptable, even though still far from ideal.

The bigger issue is your encryption mode will be probably not secure. If it is not “Full strict” the connection won’t be properly verified. The easiest fix is to install a valid certificate on your server for that new hostname and change the encryption mode to “Full strict”.

1 Like

Just a last followup to let you (and future readers) know, it’s all working now!

In the end, I had to also create an A record for “www.staging3”, and the tech person at the hosting company applied the SSL certificate to that subdomain. It was also important that I set the Proxy Status to “DNS Only”, not “Proxied”. Soon after that, I could access my staging site!

Thanks again for all your help.