Configuring SSL for subdomains

So I managed to set up my domain within the Cloudflare dashboard for a subdomain.
Lets say my domain is mydomain.com and I’d like to have the subdomain monitoring.mydomain.com to work. I’ve set up the following records:

I do not exactly know if this configuration is correct. But I think it is.
Once I’ve set these two records up, I’m able to visit the site via HTTP, not HTTPS.

What do I miss?

1 Like

Did you ckeck on Proxied?
you Only need an A record for a subdomain
in my setup i have a TXT record too.
but i am not sure if you will need it or not.

Both of the records are DNS only. So I don’t know if this is needed in order to work properly.

https://www.cloudflare.com/learning/dns/dns-records/
check this out

And what should I do after checking that?

you do not need a CNAME record !

Alright. Thanks. And what about the SSL certificate for the subdomain?
Can you help me out with that?

I am not expert with that.
but up to what i know
1st add A record to your domain
and A record for subdomain
both of them to be proxied.
and then go to SSL settings
in Overview Tab Choose FULL mode
Edge Certificates Tab check on
Always Use HTTPS
Opportunistic Encryption
TLS 1.3
Automatic HTTPS Rewrites

Sorry, but that is not good advice. You should only choose Full Strict.

2 Likes

That’s typically an indicator that your site is not secure. Did it work fine on HTTPS before you added it to Cloudflare? If not, then that’s the issue and you need to fix that first.

1 Like

Never used HTTPS before because its a server for my monitoring so I’m the only one with access to the monitoring. So I can’t really say if it worked with HTTPS before…

Do you want it to work on HTTPS?

Yep that would be awesome.

Then you will first need to fix your server and make sure it works on HTTPS.

And how do I do that exactly?

You need to talk to your host about that, that’s beyond the scope of the forum here I am afraid.

2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.