Configuring MX records


I’ve been struggling to configure the MX records for my mail domain.
I am using SiteGround and have added the records according to their guidance.

The problem occurs after moving my website from WordPress to publication tool.
As I have absolutely no programming knowledge, I’ve been struggling identifying the issue myself and hopefully will find the answer in the community.

Thanks for your support.

The name is wrong. That is not how MX records are configured, not here and not everywhere else.

The name is usually simply your domain name (or @ for short here). That can’t be what your host is telling you to put there.

That’s the answer I’ve received from SiteGround Support:

Thank you for reaching out to us!

I have reviewed the previous ticket and the attached screenshots both there and here and your records seem set correctly, but your domain seems to still be resolving towards an outdated MX from a previous host:

Code: 300 IN MX 1

As we are unable to directly assist with DNS related issues when the DNS zone is managed by CloudFlare, I advise you to contact their teams and report this. As more than 3 days have passed and no propagation seems to be present, it seems like there is a DNS related issue with the zone on CloudFlare.

Please contact them and pass on this information. Explain that you wish for all current MX records to be removed and only the following to be set as active.

Fixed the name to my domain name, but is that the only issue?!

I’ve attached a comment from SiteGround’s support, I still can’t get the email working

You have this:

; <<>> DiG 9.10.6 <<>> mx
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17834
;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 1452
;			IN	MX

;; ANSWER SECTION:		300	IN	MX	10		300	IN	MX	20		300	IN	MX	30		300	IN	MX	1

;; Query time: 121 msec
;; WHEN: Mon Apr 01 17:34:39 CEST 2019
;; MSG SIZE  rcvd: 146

The last one shouldn’t be there. The others are correct, or at least properly formatted, only your host knows if they are correct.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.