Configure MX records for emails

Hello, I have just connected my domain name with CloudFare for SSL. However there is no MX record configured. How do I configure MX record for my website abc.co.uk hosted in GoDaddy so I can send and receive emails. I’m not able to see emails in the CPANEL inbox.

You will need an IP address from GoDaddy where the mail server is hosted at. Then you need to make an A record to that IP address and then use MX records point to there. As for the other settings these depend on GoDaddy and you should ask them (or look in old DNS records there) for these.
You can add them from the DNS page of your domain by selecting the dropdown of record type and selecting MX.

A small explanation on MX records: https://www.cloudflare.com/learning/dns/dns-records/dns-mx-record/

It appears your mail is hosted by AppRiver, you’ll probably want to contact them for the proper settings.

;abc.co.uk. IN MX

;; ANSWER SECTION:
abc.co.uk. 3600 IN MX 30 mx3.p2.canit4.3d.net.uk.
abc.co.uk. 3600 IN MX 20 mx2.p2.canit4.3d.net.uk.
abc.co.uk. 3600 IN MX 10 mx1.p2.canit4.3d.net.uk

Thanks a ton. I’m half way there. From my GoDaddy, CPanel Email Inbox I can sent email and receive on my gmail. But when I send email from gmail to my GoDaddy email, I can’t see it in the inbox in CPANEL. From the GoDaddy MAIL Settings, I can see the server “xxxx.prod.ams3.secureserver.net” and I have created MX record in DNS tab of CloudFare. This is working for outgoing emails, however can’t receive incoming email. The default A record with name “mail” was already existing and was pointing to host ip, I also tried changing it to the ip of “xxxx.prod.ams3.secureserver.net”, but still can’t receive the email in CPANEL. I’m missing something silly. Please help.

That the message I get when I email from gmail to my webdomain email address >> The response from the remote server was:

550 Please turn on SMTP Authentication in your mail client. mail-qv1-f45.google.com [209.85.219.45]:45558 is not permitted to relay through this server without authentication.

Not sure what is happening but a quick search showed me this https://support.google.com/a/thread/25143484?hl=en
What is your setup, are you using Gmail webclient as well?

Thank you. Called GoDaddy support and added the records correctly.It was simple fix. Thanks for your help

This topic was automatically closed after 31 days. New replies are no longer allowed.