Configure DNS properly with Bluehost

Can you help me configure DNS properly with Bluehost and you?

What’s not working?

And can you share your domain name so we can take a look?

1 Like

Your website is working. You are using Cloudflare DNS, and it is set up properly. Your server has a valid SSL certificate and everything looks fine. However, you are not using Cloudflare’s :orange: proxy and so you have no Cloudflare security features enabled.

You should be able to turn on :orange: proxy mode and everything should work. In the Cloudflare dashboard, in your DNS settings, you can enable proxy mode, and it should continue to work, and then you can start to use Cloudflare’s security features.

Screenshot 2024-01-12 at 5.31.39 AM

Unfortunately hosting makes me turn off all the orange clouds. They don’t even know what to do, because everyone says something different. So, do I enable all the clouds in orange with the A and Cname records?

I am not familiar with Bluehost. From their documentation they are familiar with Cloudflare, so I’m surprised that they “don’t even know what to do”.

No, you should not enable the :orange: proxy mode on all your records. Those records look like they were auto-imported and some of them should not be proxied.

In order to enable Cloudflare features on your website, you would need to enable the :orange: proxy on the DNS entries for giocone.com (the root domain) and the www CNAME entry. Not the other entries, and most certainly not the MX entry.

If you enable the :orange: proxy on the A record for giocone.com and the CNAME record for www, it looks from here like everything should continue to work just the same. So do that and see if your website still works. If it doesn’t work, change it back and let us know what it looked like when it didn’t work.

But if it continues to work, then everything is good and you can begin to use Cloudflare features on your site.

Sorry?

Website work, are crawlers to not rank me… Do you have you checked what goes wrong with DNS Checker?

Seems Cname.

I’ve changed a lot of times Proxied and only DNS. I not believe we’ll solve a lot changing “randomly” these settings if you aren’t sure that works.

As told before: seems that neither Bluehost staff know what to do exactly with DNS. Every staff say a different thing:

  • DNS should point to them
  • Proxy all
  • DNS only all
  • Talk with Cloudflare
  • Some Poxy and DNS Only.

I’ve talked with them for 1 year on DNS…

What problem are you seeing? It looks fine, including on dnschecker.

To use Cloudflare you need to enable the proxy on the root domain and the www entry.

Bluehost says that the time out problems I have were due to the SEO plugin which did not generate the robots.txt file well and they inserted it on the hosting.

Do you think I can activate other DNS Proxies?

The only DNS entries that are relevant to your website are the root domain and the www entry. You should not enable the proxy on the others.

I don’t see anything wrong. If you’re having problems with timeouts you would need to isolate the circumstances under which they happen, because they are not happening right now.

ok, ty.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.