Configure Cloudflare with WP Mail SMTP

Hello,

We are having issues with sending e-mails and submitting contact forms on our website. We suspect the issue is related to some missing or wrong DNS records in Cloudfare, but are not sure. We use the plugin WP Mail SMTP, and when sending test e-mails, we receive a timeout, and when submitting a contact form we get an “error” message.

We have read the guide on how to configure this plugin with Cloudflare, but we are still not able to send out e-mails, nor submitting forms.

Any help is much appreciated.

Best regards,
Victor

What email service provider are you using with your plugin?

We are using our hosting provider’s SMTP server.

Are you using their domain name or your domain name to connect to it?

We have tried both our domain name and their domain name. If it’s of any help, here’s how the mail records are configured in Cloudflare

You definitely have email related DNS problems.

  1. Delete the mail CNAME
  2. Add a :grey: A record for mail using the same IP as your apex domain
  3. Edit your MX record and add mail. to the beginning of the current hostname

If you are still having difficulty once that is completed, let us know.

Thanks for the advice. We tried the suggested solution, but it didn’t solve the issue, unfortunately. Here’s what the settings looks like now:

We have used mail.bubliq.com as the SMTP host in the plugin. We’ve also tried with our hosting provider as SMTP host, but it didn’t work either.

Maybe I am missing something?

Quite possibly and it is very likely that it is beyond DNS at this point. Keep the DNS changes you made that I referenced. They are good. I am able to reach your mail server on port 25. I didn’t test 587 or 465, but you probably should since port 25 is sometimes blocked.

You are going to need to do some basic SMTP troubleshooting at this point. If you have shell access to the webserver, I am partial to using openssl s_client. It will come with a little learning curve of you have never used it, but there are many references online. This one appears to be decent.

This might be a good time to engage with your host or the plugin developer for additional support if you need it.

Thanks a lot for your suggestion. Will definitely give this tool a try and reach out to the plugin support and hosting provider for more guidance.

EDIT:
By changing the port to 25 or 587, I immediately solved the issue!
Port 465 doesn’t work for some reason.

What a relief - thanks a lot again!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.