Community Tip - Fixing SSL ERROR NO CYPHER OVERLAP in Mozilla

CommunityTip

#1

Error
Try the suggestions in this Community Tip to help you fix SSL ERROR NO CYPHER OVERLAP in Mozilla.

Background
A website using HTTPS performs a series of steps between the browser and the web server to ensure the certificate and SSL/TLS connection is valid. These include a TLS handshake, the certificate being checked against the certificate authority, and decryption of the certificate. If Chrome detects an issue, it might display “SSL_ERROR_NO_CYPHER_OVERLAP” which prevents access to the site.

Quick Fix Ideas

  1. Grey-cloud/deactivate Cloudflare so that the website uses the origin’s SSL certificate
  1. Re-start the process
  • Go to Crypto tab on your Cloudflare dashboard and scroll down to the bottom
  • Click the Disable Universal SSL
  • Wait for a few minutes then click the Enable Universal SSL
  1. Understand how the certificate works
    Certificates will only cover a single level of subdomains (.example.com, but not *…example.com):
  1. Wait 24 hours, in most cases, this is just a timing issue. Check if you have an active SSL certificate under Crypto tab, if it it says “Initializing Certificate”, wait until you see Active Certificate. Pause Cloudflare in the meantime.

Lite Reading

Background Resources
Knowledge Base
YouTube

Research The Issue
Community
Google

If You Need More Help
This community of other Cloudflare users may be able to assist you, if not, login to Cloudflare and then contact Cloudflare Support. When you contact support, make sure to include as much of this information as possible: error messages, screen shots, and/or HAR file(s).

Expert Comments Appreciated
This Community Tip will remain open for input from Community experts and those familiar with this issue. We really appreciate comments that start with words like: “The three things I always try”, or “Do this first” or “In my experience”.

This is a Cloudflare Community Tip, to review past tips click here.


It's been over 24 hours for SSL
#2

#3

This topic was automatically closed after 7 days. New replies are no longer allowed.