Comments gone missing, Cloudflare is the main suspect. Any idea what is wrong?

I run a WordPress site that got a good volume of comments (~1,4k monthly). Last July, I started using Cloudflare in a new hosting, and so an annoying issue appeared: for some readers, commenting became impossible.

When they comment, no error message is shown, but their comments just vanish. They aren’t caught by Akismet or pending approval, so I started digging with some help from my hosting support to find what was wrong.

My hosting support was suspicious of Cloudflare, and after trying several settings adjustment, earlier today I paused Cloudflare completely on that domain. This “solved” the issue, but I can’t afford having no CDN, so I need to find what to tune on Cloudflare to avoid those false negatives on filtering/blocking/whatever it’s doing to those legitimate comments.

Any idea about what could be?

Welcome to the community!

Just to know, do you have Rocket Loader enabled? If so, try to disable it.

Hope it helps!

No, Rocket Loader is disabled.

I’ve tried several tweaks and different settings, unfortunately the only thing that solved the issue was pausing Cloudflare completely. My best guess is that there is one setting that I wasn’t able to find yet that does the trick.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.