Coming Soon page of Godaddy- they say it's Cloudshare

I’ve got a website that says “coming soon” but I had cloned another site (which I’ve done many times) and this one is not working. Godaddy says the issue is with an A-Record at Cloudshare but I’ve compared those records to another site that works and they look the same in the A-Record area.

I just uninstalled the site from installatron and cloned again to start something, and it’s still not coming up. The padlock is still green. Godaddy had initially told me that the issue was it needed SSL. So I got it. Still doesn’t open. Then they told me it was an a-record issue.

Newbie here. Use small words and go slow, please.

1 Like

https://community.cloudflare.com/search?q=future%20home%20of%20something%20quite%20cool

1 Like

Thanks, I did a search… Got most of those same results. I didn’t think my question fit most of these responses. But, I’ll look again.

Hi @arritola68,

I would recommend in particular:

1 Like

Thanks. I saw that one and did what I could on that list. I don’t understand how to do some of them. I’ve just deleted my site from cloudflare and started over. I’ll wait a little bit and see if it ca open.

I see another solution is " The problem is that some resources (CSS and JS files) are loaded without HTTPS encryption. You need to change the http:// to either https:// or just // where you load the resources. Alternatively you can let Cloudflare do it for you: In the Cloudflare dashboard under Crypto, enable “Automatic HTTPS Rewrites” and “Always use HTTPS”. Hope this helps."

I do not see Crypto on my dashboard.

No it is neither an issue with an A record nor with Cloudflare. It is the usual issue with Godaddy and I’d actually strongly suggest switching to a better host as their support makes their lack of competence obvious again and again.

The issue is Godaddy hasnt configured a proper certificate for your domain on their server - as is necessary in order to run HTTPS; and no, Cloudflare cant fix that either - and hence shows that default page instead of your domain.

Godaddy needs to fix that and Godaddy alone, but again I strongly recommend to find a host who actually knows what he is doing.

Thanks, Sandro. Is that how I can describe the issue to them when I call back?

Basically yes. Tell them you need a properly valid (for your domain and by an official certificate authority) certificate configured. There is a good chance they want to charge you, at which point you could ask why you cant have a perfectly acceptable free Lets Encrypt certificate or even have one of Cloudflare’s Origin certificates installed on your server.

They might still want to charge you, but then did I already mention switchin hosts is a good idea? :slight_smile:

1 Like

You mentioned that. For the most part, except for today and this issue, I’ve been happy with Godaddy. I tried another host once and it was horrible . A host that was VERY recommended, likely because they have a affiliate program. Godaddy def wants to charge me for this. When I called them earlier he said Cloudflare only secures part of the connection and that I would need Godaddy to secure the rest. But that shouldn’t affect this issue because I have 12 other sites doing exactly the same thing and they all work.

I’m not a pro (newbie, self taught, trial and error) and I cannot afford SSL for all of them. Trying to find a free way to solve this for little bitty sites.

I stuck with Godaddy because it was super easy to… register a domain, no messing around and the hosting was inexpensive in the beginning… ad other than today, they always help me. I’m calling somebody in the country and they answer the phone and are pleasant. Not so with the OTHER host I tried.

So, I get it… but whenever I check on reviews of other hosts… I hear similar stories.

You need a certificate on your server if you want HTTPS.

Here’s a link to instructions for getting an Origin certificate that @sandro mentioned. At the bottom of the article is a link that might work for GoDaddy.

2 Likes

Sorry, I’m not sure I understand. In fact… I’m certain I don’t. I’ve only got the free SSL from Cloudshare on all my sites, and all of them have the green padlockk.

That will mean you will have a highly insecure setup on Cloudflare and all your sites are actually still insecure.

I am sorry, I wont go more into this topic, as this has been discussed endlessly and yet another lengthy thread is pointless.

Fact is, if you want a secure site you need a certificate on your server. @sdayman’s link should give you a start.

I’m still waiting for that page to open. In the meantime… what can I search for- corect phrase- to find a free solution to my SSL ?

The link @sdayman posted explains it all and I referred to another solution in an earlier posting as well.

Thanks, it just opened. I’ll work on this. Thanks all.

uhm,… this looks really familiar. I think I’ve done this for all my sites except this one I’ve had an issue with. Is there an easy way to determine if all the other sites are completed?

I did a google search and found this site to test my sites to determine if they are secure… and it says yes…https://www.sslshopper.com/ssl-checker.html#hostname=dachia.net

I get green checkmarks all the way down. Have I resolved my issue and am now just waiting for everything to populate and catch up?

Can I trust ths site?

I am sorry, this has been discussed way too many times. This will be my last response, not only because it was already stated what you should do.

The response you are getting on that site is because it only checks Cloudflare’s proxies but not your own site, where - as mentioned several times - you need a certificate but dont have one.