Codes Not reflecting in the website


#1

Hi, I enabled development mode to update JS and CSS files and it worked. After 3 hours (as mentioned in documentation as well) the mode become disabled automatically. Now, when we enabled development mode again, it is updating js css files (as we are enabled to view js/css files in browser). But it is not reflecting in website. Even when we renamed the js file, still the original older js file functionality is working, though it should not work.

There is some caching problem in my website due to which though the JS files are getting updated but the changes are not visible to the website. I used cache purge But it worked single time and again the same problem.I have tried to purge again but no luck.


#2

When a file is cached, it stays in the cache for however long Cloudflare keeps it. Hours/days/whatever.

When you go into dev mode, you bypass the cache. When you exit dev mode, you start reading from that cache again. The cache doesn’t clear when you enter or exit dev mode.

So…that older js file looks like it’s still in the cache, which is normal.

You say you used cache purge. Did you purge everything? That’s my approach since I’m never entirely confident I’m getting the path and file correct. Once your purge, if you look at the headers for that HTTP transaction, you should see some cache information, like HIT/MISS, etc., and the cache expiration. I use Chrome or Firefox’s Dev Tools for this.