"code":1068,"message":"Permission denied"

My cloudflare script was working perfect until i create new account. I tried to run my script with new Global Api Key but got “code”:1068,“message”:“Permission denied” . Get requests are working perfect, post request is not working, im getting permission denied but GLOBAL API KEY has the highest permission. How can i fix that, i even created new account but still not working with new account.

curl -X POST “https://api.cloudflare.com/client/v4/zones
-H “X-Auth-Email: [email protected]
-H “X-Auth-Key: GLOBALAPIKEY”
-H “Content-Type: application/json”
–data ‘{“name”:“domain.com”,“account”:{“id”:“accountid”},“jump_start”:true,“type”:“full”}’

In the example that you posted, you should have updated Auth-Email, the Auth-Key, and the Account ID.

1 Like

I changed everyting to new account, email, apikey, everything. As i said get and delete requests are executed well

You really need to delete that info. Just delete the entire reply and it should roll off the system. @cloonan might also be able to fix that.

1 Like