Hello, I’m trying to change my nameserver on my website but when I add the 2 nameservers, I encounter this error:

< test name=“CNAMEHostTest” status="FAILED ">
< detail name=“” status=“SUCCEEDED”/ >
< detail name=“” status=“SUCCEEDED”/ >
< detail name=“” status=“FAILED” queryId=“11” >Unresolvable host< /detail>
< /test>
< /tests>

I contacted my host support and they told me to write back here. Could anyone help me?
Thank you in advance
EDIT: put spaces so you can read exactly what they told me:
EDIT 2: Maybe this thread could help me but I still can’t understand what op did

Did they tell you to add a CNAME record for verification? If so, try setting it to :orange: and see if that helps.

Hi sdayman, thank you for your reply :slight_smile:
I quote: “Nel dettaglio, fallisce : - CNAMEHostTest: verifica che i nameserver presenti nei record SOA, NS e MX, se presenti, non siano dei CNAME.”
Translated: “CNAMEHostTest fails; verify that the nameservers found in SOA,NS,MX records, if found, aren’t CNAME”

Maybe @matteo is still awake. There are frequent problems with .it domains, but I don’t recall ever seeing one about CNAMEs.

1 Like

I am, of course, still awake! I have never seen any errors with CNAME as well, also normally NS and SOA are not CNAMEs. Maybe MX records are, but would that be an issue with anything?

Can you share your domain @Mario_Rossi? (PS: is that really your name?! I bet it’s often cause of confusion…)

The record for your MX entry does not exist. Add an additional A record named “mx”, make sure it is not proxied, and point it to the server which should receive your email. That should fix it.

Hi matteo, thank you too :smiley:
My domain is (yes, it’s very slow) hosted on Aruba.
ps. Nope, Mario Rossi isn’t my real name, I’m gonna change it soon haha

Hi Sandro :slight_smile:
You mean like this?

It’s already in this way

No, I meant exactly what I wrote :wink:

An A record, what you have here is an MX record but no matching A one.

Saw you already put it above…

Cool, better for you ahah

Suggestion. Put one of the IP addresses that Aruba gave you instead of there, change NS and then after they are accepted switch back.

An MX record must not contain an IP address. It really is easy, just add the mentioned record, thats a thing of a few seconds.

It’s that per spec? Because as of now the record is a number of IPs already (per standard Aruba settings).

RFC 1035 as far as I can tell. It is not impossible but it shouldnt be done.

Not on Cloudflare. The OP does not have that record configured, hence I “suggested” that :wink:

You are true, my fried… sorry about that and @Mario_Rossi follow what he said.

Sorry Sandro :slight_smile:
Okay guys, I did it after reading what Matteo said about IPs so I added one of the ip that Aruba gave me:

In this way I was able to add cloudflare Nameservers, but I guess I have to wait 24.48 hours.
Do I need to change it to and leave blank the second field?

Well, that is exactly what I suggested. What do you need to wait for? The record is in place and the error shouldnt be there.

You wrote “An MX record must not contain an IP address.” so should I change it?
If I check my domain with, it still says me that I have the old Nameservers

What is unclear about what I wrote half an hour ago twice? I never said you should change your MX record.

The configuration is correctly in place now it seems and you dont get the error anymore.

1 Like

Sorry, I thought you meant even in different fields, but now I get it.
Now I just need to wait, right?

Not sure what you need to wait for. You seem to have implemented what was suggested and you should simply change the nameservers.