CNAMEHostTest Failed for an italian domain assigning nameservers

Hello,
I know, there are several threads related to italian domains and I already tried to follow their “cases”. I also already asked for support to my domain registrar and the hoster but nobody is able to solve this problem.

Prior note: in the past I had the lcweb.it domain assigned to cloudflare through the hoster cPanel tool (now discontinued). Now I need to directly set the domainn nameservers to Cloudflare in order to change hoster (the new hoster nameservers are not recognized by the italian NIC…!!!) .

Second note: I am a software developer, not really skilled inn DNS and these matters.

The nameserver assigned to the domain are:

  • joan.ns.cloudflare
  • roan.ns.cloudflare

When I validate them (https://www.nic.it/en/manage-your-it/dns-check) I get this error:

CNAMEHostTest failed: Unresolvable host _dc-mx.948c03d61f51.lcweb.it.

 


 

NB: My hoster already added the 948c03d61f51.lcweb.it. DNS

Will I find anyone on this planet able to solve this absurd situation…?

Thanks to anyone will shine a light.

You have not set the 2 Cloudflare name servers at your registrar…
https://cf.sjr.org.uk/tools/check?4eb9e0336cc14ca6bf3449c3b30a7395#whois

If you did previously, and it didn’t work so you’ve set them back, it is better to “Pause Cloudflare” than keep changing nameservers due to the propagation time.

_dc-mx.948c03d61f51.lcweb.it usually means the target of your MX record is a proxied hostname, so Cloudflare unproxies it so you can receive mail.

When using Cloudflare for DNS, you do not use your host’s DNS.

On italian domains, nameservers must be accepted by NIC (DNS Verify | Registro .it). Not passing the check, I cannot assign the Cloudflare nameservers in my registrar.

In few words: what do I have to do?
This is the only MX record in my hosting DNS panel

You will need to assign the Cloudflare nameservers or you cannot use Cloudflare (unless you have a Business or Enterprise account and a partial CNAME setup).

I assume to get this check to pass, they are checking that the new nameservers have certain records. Those records exist in the nameservers while it is in a pending status at Cloudflare, they just aren’t proxied.

dig +short lcweb.it @joan.ns.cloudflare.com
50.31.114.44
dig +short lcweb.it mx @joan.ns.cloudflare.com
0 _dc-mx.948c03d61f51.lcweb.it.

The MX record is deproxied and returning a CNAME. The error message says it is checking the MX and finds an error. Delete the MX record from your Cloudflare DNS for now and see if the check passes then.

You do not need to add this MX record at your current DNS.

1 Like

Man, do you know you solved the whole situation with two replies and in 5 minutes?
It’s 3 days I’m begging any (pay) service I use to help me with this, but gave me a valid answer.

I simply had to remove the MX DNS on cloudflare!
And I even paid 20$ to get Cloudflare support :grin: (that by the way never gave me an answer in 3 days!!!)

Actually propagating… let’s keep the fingers crossed

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.