CNAME "www" is not propagating

Why my CNAME “www” is not propagating. I made DNS settings around 10 days ago but it is still not propagating. When I disable the CNAME proxy, it starts propagating while as I enable the proxy later after the propagation is completed, it again stops propagating. Please let me know how to fix it. Thank you

My domain is worldfindings. com

Regard,
Atif

https://www.worldfindings.com/ loads normally for me, it’s proxied through Cloudflare, and the https://worldfindings.com/ apex domain (also proxied through Cloudflare) redirects to WWW.

What makes you think it’s not working? Have you restarted your browser or tried it from another browser?

$ curl -LI https://www.worldfindings.com
HTTP/2 200
date: Sun, 10 Jul 2022 12:32:14 GMT
content-type: text/html; charset=UTF-8
last-modified: Sun, 10 Jul 2022 12:16:43 GMT
vary: Accept-Encoding
content-security-policy: upgrade-insecure-requests
referrer-policy: no-referrer-when-downgrade
pragma: public
cache-control: max-age=3600, public
alt-svc: h3=":443"; ma=86400, h3-29=":443"; ma=86400
x-turbo-charged-by: LiteSpeed
cf-cache-status: DYNAMIC
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=RpHBKsJKy1V9TwP2xPAUtIDG3wk5iC9dq0eC7d9Qkw1ek2f5rkSnPEkIM53HchsGGJ80iihC3Y%2BL%2BR5%2BjUlCOxx5imJFIpG0OH%2BVexeeP2yNCUTjGfonbQvBlO76lCpIvn9bxOf72X7bb0PnoA5rHSmJ20o%3D"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 72895225dc9a8134-ORD
$ curl -LI https://worldfindings.com
HTTP/2 301
date: Sun, 10 Jul 2022 12:32:40 GMT
content-type: text/html; charset=UTF-8
location: https://www.worldfindings.com/
set-cookie: dwqa_anonymous=c2hse3igwolmfv02SrT4SJaxSwrUJmkhxlMxRdsnKf6; expires=Wed, 07-Jul-2032 12:32:40 GMT; Max-Age=315360000; path=/; secure; HttpOnly
expires: Sun, 10 Jul 2022 13:32:40 GMT
cache-control: max-age=3600
x-redirect-by: WordPress
content-security-policy: upgrade-insecure-requests
referrer-policy: no-referrer-when-downgrade
alt-svc: h3=":443"; ma=86400, h3-29=":443"; ma=86400
x-turbo-charged-by: LiteSpeed
cf-cache-status: DYNAMIC
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=UAuqu2RC%2B67GlDMGfsju%2Fv6uiieCF8Uk6RpqQL8w%2BBG7XbyET6dd%2Bs59IxMVpXKYo%2BNPd7DOXz78Eo4omwjyL1VAJvme7HTLOaiT%2BXmMSEtfaFOnYzJkH%2B5VFrkyWs%2Bb6zFK%2F1KG9er9%2FcuSqcK5JA%3D%3D"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 728952c5aeef2a4e-ORD

HTTP/2 200
date: Sun, 10 Jul 2022 12:32:41 GMT
content-type: text/html; charset=UTF-8
last-modified: Sun, 10 Jul 2022 12:16:43 GMT
vary: Accept-Encoding
content-security-policy: upgrade-insecure-requests
referrer-policy: no-referrer-when-downgrade
pragma: public
cache-control: max-age=3600, public
alt-svc: h3=":443"; ma=86400, h3-29=":443"; ma=86400
x-turbo-charged-by: LiteSpeed
cf-cache-status: DYNAMIC
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=gYIIp0QWtCg6ylBkqr91259hmc0PVzalgyMKeS97BkQBJLghggxn1D1V1cgwMHLuh3jvRd8l6jJQJIUuiQpP%2FQsPr1HnquKIMFfO9ICtUq1ZmZbqG8Sz7JFlnFKRYrsr9U6dg11AohpxQQEoXeIbW5Vbqf4%3D"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 728952d038f186da-ORD

Hey, thank you for your response. I don’t know why the CNAME www is not propagating. Please check my CNAME www from the DNS checker tools and you will find all X. When I disable the proxy for the CNAME www then it starts propagating. But, it again stops propagating when I enable the proxy. Please let me know what to do in this case. Thank you

Regard,
Atif

Proxied records (:orange:) will not return a CNAME - it will return A/AAAA records as the traffic goes to Cloudflare who then fetches the CNAME on your behalf.

;; QUESTION SECTION:
;www.worldfindings.com.		IN	A

;; ANSWER SECTION:
www.worldfindings.com.	300	IN	A	104.21.4.176
www.worldfindings.com.	300	IN	A	172.67.132.80
3 Likes

Please assist me in a better way how to fix this issue. I’ve noticed that the website is working with www but when I check CNAME www in the DNS checker tool, it is not propagating. Also, it shows that the CNAME www is not added by some speed checker tools.

It isn’t an issue, it’s how proxying works.

Just change your lookup to A/AAAA records, not CNAME records.

1 Like

Thank you for the response. Actually its an issue for me. It decreases my website SEO score and also the speed of my website. Please let me know why the CNAME www is not propagating when the proxy is enabled?

Cloudflare uses an anycast network - this means that lookups for a proxied record return Cloudflare’s IPs.

If you don’t want this to happen for a CNAME, your only option is to set the record to DNS only which removes Cloudflare’s services from that record - i.e proxying/caching/firewall.

https://developers.cloudflare.com/dns/additional-options/cname-flattening/#for-all-cname-records

proxied records are flattened by default (as they return Cloudflare edge IPv4 and IPv6 addresses).

https://developers.cloudflare.com/dns/manage-dns-records/reference/proxied-dns-records/#proxied-records

When an A, AAAA, or CNAME record is Proxied — also known as being orange-clouded — DNS queries for these will resolve to Cloudflare Anycast IPs instead of their original DNS target. This means that all requests intended for proxied hostnames will go to Cloudflare first and then be forwarded to your origin server.

This behavior allows Cloudflare to optimize, cache, and protect all requests to your application, as well as protect your origin server from DDoS attacks

CNAME flattening (returning A/AAAA) is quicker than CNAMEs anyways - so I don’t follow how it hurts the speed of your website.

1 Like

2 posts were split to a new topic: Low performance and SEO when proxied

When I try to check in the DNS checker tools whether the CNAME www is propagating, it’s not.

You have two choices:

  1. :orange: Proxied
  2. :grey: DNS Only

That is all.

As the original question was answered, I’m closing this thread.

1 Like