CNAME stopped working

One of my CNAME entries stopped working.

Our webhost has us use a CNAME from root, and thanks to Cloudflare’s CNAME flattening, that works well.

In order to let users use www in front of our root, we have a CNAME with host of www and value of @.

That was working fine until today we noticed it no longer works. It’s just a blank browser screen after entering.

Checked with the webhost and they said nothing changed on their end.

Any ideas what to check or to validate?


Is it set to :orange: Proxied, or :grey: DNS Only? Try switching it to the other and see if anything changes.


Thanks for looking at this!

It was set to Proxied, both now and when it was working before.

Tried switching to DNS Only, but no luck.

Which SSL setting are you using? It should be Full (Strict), and your webhost should also have SSL set on the server for that hostname. If that’s all in place, your host should be able to see the requests in the server logs.

Thanks again!

It’s set to Full. I didn’t think I could use Full (strict) because we don’t have an origin CA certificate on the server. But maybe that means the webhost has to have that, and I believe they do. I will check with them and also check whether they can see requests in the logs.

I was also poking around a little and thinking I could set up a page rule to do the same thing the CNAME was doing when it worked.

What was it doing? If it was redirecting to ‘www’, and ‘www’ still works, definitely do it with a Page Rule instead. Match* and 301 redirect to$1

1 Like

Yeah, that’s similar to what I tried. I was just on my way back to write it up.

I flip-flopped your suggestion, so* does a 301 redirect to$1

Same idea, and seems to do the trick.

Thanks again for taking the time to look at this!

1 Like

That’s strange. I thought it was the root hostname that wasn’t working.

Sorry, and maybe I shouldn’t have included that in the OP. I was trying to give context that the root was working (thanks to Cloudflare CNAME flattening).

The CNAME for www used to work, but stopped at some point. The value for the www host is the root.

1 Like

Which SSL setting would you say you are utilizing? It ought to be Full (Strict), and your webhost ought to likewise have SSL set on the worker for that hostname. In case that is all set up, your host ought to have the option to see the solicitations in the worker logs.

1 Like


SSL is set to Full (Strict) now. It was just ‘Full’ before. But unfortunately that didn’t make a difference for the www CNAME record.

They do have SSL set, not sure what they have seen in their logs, though.

It does sound like maybe something changed on their end, though. Because when I first set up the DNS entries, worked, as did just And since then, have not made any DNS changes.