CName still not Propogating still pointing to old site

I am moving my website from shopify to another host and was instructed to set up a Cloudflare account. All the changes I made to my DNS propagated within an hour until I changed the nameservers to Cloudflare. The site now points to the old site, the CName isn’t updating and it has been nearly 48 hours. I know they say that it can take this long or longer, but this doesn’t seem right.

Whatsmydns shows the nameservers as pointing to Cloudflare, but still no resolution with the Cnames. Please advise. I’m losing business by the hour.

Hi @Dames,

If you set the records to :grey: and wait 5 minutes. does it resolve to the new site OK?

Shopify use Cloudflare and it may be that they haven’t removed your domain from their setup properly.

That seems to be… Now what do I do? Do I just leave it this way?

I’m a total novice with this…

For now, leave it :grey: so the site at least works.

Then go back to Shopify and ask them to remove their Cloudflare configuration for your domain, specifically SSL for SaaS / Custom Hostnames. Once they’ve done that, you should be OK to go back to :orange: and get the benefits of Cloudflare.

It still isn’t working. The CName records now resolved… But shopify says they don’t know anything about the cloudflare configuration and insist that the site is no longer listed with them despite the fact that it is still pointing to them after nearly 50 hours. I’m at a complete loss.

I’ve deactivated my proxy settings and that managed to resolve the fact that my CNAME records weren’t updating. But my website STILL points to the old host after over 48 hours.

When the CNAMEs are :grey:, it still shows the Shopify site and not the new one?

Can you share the domain and the instructions given by your new provider?

domain was lymphedames.co.za

. Sign up for a CloudFlare account from cloudflare.com if you do not already have one.

  1. Enter your domain name then click Add site.

  1. Select a plan of your choice (you can avail the free plan as well).

  2. Click Confirm plan.

  1. Click the Record type pop-up list and choose CNAME.

  2. Enter your root domain name (yourdomainname.com) in the Name field.

  3. Enter www.yourdomainname.com (with the www) in the Domain name field.

  4. Click Add Record.

  1. Click Continue.

  1. Follow the on-screen instructions to update the name servers in your DNS manager.

  1. Go back to CloudFlare and click Done, check nameservers.

Now, you can access your Zoho website by entering your domain name either with or without the www.

Forgot to answer this one… Yes. when the CNAMES are grey it still shows shopify

When the CNAMEs are :grey:, it still shows the Shopify site and not the new one?

Your www points to Zoho and redirects to lymphedames.zohocommerce.com. Is that what’s expected?

The root domain still points to a Shopify IP, can you change that to the CNAME asked for by Zoho? Leave them both :grey: as per their instructions.

The root domain still points to a Shopify IP, can you change that to the CNAME asked for by Zoho? Leave them both :grey: as per their instructions.

I’m not sure what you’re referring to here… I’m not sure how to do this…

The root domain still points to a Shopify IP, can you change that to the CNAME asked for by Zoho? Leave them both :grey: as per their instructions.

I’m not sure what you’re referring to here… I’m not sure how to do this…As far as I can see, everything is pointing to Zoho…

lymphedames.co.za still has an A record pointing to an IP that is Shopify’s (23.227.38.32). You should remove that and add the CNAME in the list from Zoho.

These were the instructions I followed from Zoho’s website:

https://help.zohosites.com/using-root-domain

Using your root domain as the primary domain of your website

It is not possible to set the root domain (domain name without www) as the primary domain in your Zoho website.

However, if you have configured your domain as mentioned in Domain Mapping, users can access your website by entering your domain name either with or without the www.

If you want only your root domain name (domain without www) to be set as the primary domain, you may use CloudFlare, a third-party service provider to meet this requirement.

Note: CloudFlare is not affiliated with Zoho Sites. The steps listed below will enable your domain name to appear without the www in the address bar of your browser when visitors access your website.

  1. Log in to your Zoho Sites website builder.

  2. Click Settings at the top of your builder.

  3. Click Domains below the Configure section.

  4. Make your root domain as primary

  1. Sign up for a CloudFlare account from cloudflare.com if you do not already have one.

  2. Enter your domain name then click Add site.

  1. Select a plan of your choice (you can avail the free plan as well).

  2. Click Confirm plan.

  1. Click the Record type pop-up list and choose CNAME.

  2. Enter your root domain name (yourdomainname.com) in the Name field.

  3. Enter zhs.zohosites.com in the target field. If your site is hosted in other Data Centers (DC). Modify the target field value as shown in the below table.

DC Target
US DC zhs.zohosites.com
EU DC zhs.zohosites.eu
IN DC zhs.zohosites.in
CN DC zhs.zohosites.com.cn
JP DC zhs.zohosites.jp
AU DC zhs.zohosites.com.au
  1. Click Add Record.

  1. Click Continue.

  1. Follow the on-screen instructions to update the name servers in your DNS manager.

  1. Go back to CloudFlare and click Done, check nameservers.

Note: CloudFlare is not affiliated with Zoho Sites. The steps listed below will enable your domain name to appear without the www in the address bar of your browser when visitors access your website.

Here are my current configurations:

This is still what you need to do.

Does this look right?

Yes, you should probably either have both that and www set to :orange: or :grey:. I would personally suggest you set them both to :grey: for now at least while you’re getting everything working.

How do I look up who an IP address belongs to. There are a few on here that I don’t recognize or am not sure about.

You can use whois or an online tool like https://who.is/. It sometimes shows a service provider rather than the actual service you use but can help.

Both the IPs for info. seem to point to Amazon. That could be from a direct setup with them or another service provider you used who used them.