CNAME redirected doesn't seem to be updating

Hey there, I’m having a bit of a problem with a CNAME redirection and hope you guys can give me a hint.

I have added a CNAME record to redirect cursoaba.comunidademundoazul.com.br to comunidademundoazul.academiadoautismo.net

The redirection is working and it’s not proxied. The problem is, when I update comunidademundoazul.academiadoautismo.net it does not reflect on cursoaba.comunidademundoazul.com.br. I’ve already tried to purge all cache and even tried to make a new CNAME redirection but to no avail, it still does not update.

What should I do to solve this and what should I do when I need to update the origin at comunidademundoazul.academiadoautismo.net and have it reflect immediately on cursoaba.comunidademundoazul.com.br.

I also tried turning on the “Development Mode” to hard disable all cache but it also didn’t help.

Thanks in advance!

Hi there @vitor_r_castro castro

I can see that you have a CloudFRONT layer at your origin that is caching some of the external resources over at https://comunidademundoazul.academiadoautismo.net/:

Do you have control of the external server where these resources are hosted? If so, you’ll want to look into purging cache from the CloudFRONT layer as this may be reason why you do not see changes reflect even after purging cache from CloudFLARE.

So, I do have control over the Cloudfront origin but that’s not really the problem.

The problem is, I created cursoaba.comunidademundoazul.com.br and did not put anything in it at first. So I configured all the Cloudflare DNS and CNAME redirection. After the DNS propagated and cursoaba.comunidademundoazul.com.br started pointing in the right direction I went ahead and published a single HTML file in comunidademundoazul.academiadoautismo.net.

The real problem is, as you can see in the screenshot below, when I hit cursoaba.comunidademundoazul.com.br it does not load the HTML I have published, instead it loads the default server page and I can’t seem to get it to load the index.html correctly.
I’ve tried putting the full path, with index.html, in the address bar but it also didn’t work.

All I need to know is why cursoaba.comunidademundoazul.com.br is not loading the contents at comunidademundoazul.academiadoautismo.net, instead it seems to be stuck on some kind of cache that I can’t find out how to purge.

I even tried creating a new CNAME, pointing to the same destiny aba.comunidademundoazul.com.br but it just shows the same wrong content.

Ah, I see what you mean. This is happening due to the Host header being sent in the request. You see, when a request is sent to cursoaba.comunidademundoazul.com.br, it is forwarded to the target destination with the Host header that does not match the origin server, and therefore you see that error message.

You can always use a Page Rule to forward to the URL in question.

Say for example:

Note, that your DNS record for cursoaba.comunidademundoazul.com.br would need to be proxied (orange cloud) in order for the page rule to apply.

That message is not an error message. You see, when I create a subdomain on the target hosting it creates a few default HTML files, that’s what we’re seeing in the browser screenshot I provided.

The problem is I already changed that HTML file, it doesn’n even exist anymore on the target host and yet I still see the same message when I hit cursoaba.comunidademundoazul.com.br

The forwarding you suggested wouldn’t solve the problem, because I want the domain to be comunidademundoazul.com.br, for Facebook Pixel purposes. If I just redirect, then I’ll lose that domain and my Facebook Pixel events will be fired from the wrong domain.

I even tried to upload a static image file on the target server to test

404 via CNAME: http://cursoaba.comunidademundoazul.com.br/fb_graph.jpg
200 directly on the target host: http://comunidademundoazul.academiadoautismo.net/fb_graph.jpg

HTTPS gives 503 error and is not being proxied via Cloudflare (:orange: cloud), while HTTP is not being proxied via Cloudflare (:orange: cloud), so I believe the created Page Rule would not work for your sub-domain cursoaba record.

If I wanted a page rule to match subdomain.example.com , then I would need to add a DNS record for subdomain and set it to :orange:.

Firstly, the domain comunidademundoazul.com.br should be added to your Cloudflare account.
Next, checking and in case if missing, add a CNAME @ with content value academiadoautismo.net, having it :orange: cloud and hopefully Full SSL option being enabled.
Furthermore, adding a CNAME comunidademundoazul record with content comunidademundoazul.academiadoautismo.net, being :orange: cloud and also with Full SSL option enabled.
Third, a Page Rule below should do the work:

    cursoaba.comunidademundoazul.com.br/*
    Forwarding URL 301
    https://comunidademundoazul.academiadoautismo.net/$1

Just did the page rule and it does not solve the problem. As I said in response to blas, I need the root domain to be comunidademundoazul.com.br because of Facebook Pixel events, that’s why I chose the CNAME way.

When I redirect via page rules I lose the domain and I can’t fire the pixel events anymore. Considering this case in particular, I can’t redirect, I must always browse via cursoaba.comunidademundoazul.com.br

The CNAME wasn’t proxied because when I turn on proxing I get the 503 error.

I’m not worried about the SSL at the moment, I just want my CNAME to load the contents of the target host without any caching. Is it even possible with Cloudflare?

I am afraid I do not understand the needed setup you want to achieve regarding the Facebook Pixel events.

Is that 503 error comming from your host/origin server or Cloudflare end?

Okay, but would be beneficial if you go with HTTPS nowadays. I believe it is possible, but could be I am wrong about this one.

Maybe below articles could help to figure out about CNAME flattening as you want a CNAME record for a root domain?:

Kindly and patiently wait for someone more experienced to reply to this topic. @sandro @cscharff

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.