CNAME records not propagating


#1

Hey guys,
A service I am using has asked me to create CNAME records for my domain. I created them almost 24 hours ago, but the service is still not detecting them, and various online DNS zone scanners I have tried also do not show them yet. This seems like an unusually long amount of time? If I add a CNAME record at my registrar, it usually propagates in under an hour. Let me know if I’m missing something or doing something wrong!


#2

My guess, it is proxied and hence not recognised.

Whats the record?


#3

I have created the following records (they should all be pointing to Microsoft Azure):

  1. blobcdn.kickfox.com
  2. app.kickfox.com
  3. *.kickfox.com

#4

No such CNAMEs seem to exist. Can you post a screenshot of your DNS settings?


#5


#6

As I suspected, the entries are proxied. You’ll need to switch to :grey:.

What’s surprising though is they do not resolve at all. Try if switching them to :grey: fixes it and possibly also remove the * wildcard.


#7

I added them just about 22-23 hours ago now I’d say… ¯_(ツ)_/¯


#8

Thanks, I will try that now and return, however I thought the proxy was still allowed? When I directly type in app.kickfox.com in my browser, it actually worked fine. It’s just not being detected by Azure, or you? I’m confused


#9

It now seems to work fine. Do you need them for verification or for service access?


#10

Verification, yes. I just tired again and voila Azure has detected it. Should I not turn the orange cloud back on? Or leave it gray?


#11

If it is only for verification you can delete it now altogether I assume.


#12

Thank you so much, everything seems to be working as expecting now! I’ll make a note of disabling the proxy for verification. Have a wonderful day!


closed #13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.