Cname records doesn't seemt to be updating

So the cname records sits nice and patiently in the admin panel. It’s been probably ~30hours. Atleast 24.
There used to be a records, which i deleted after i had added cname records. I don’t know what the ttl was on the a records. If the ttl on the now deleted A records were many days would it affect not seeing cname records at all?

cname: @, www

How are you detecting that the records are not updating?

With :orange: hostnames, tools like dig and nslookup cannot see the underlying value you have set, and users only get A and AAAA responses with Cloudflare IPs in the response (even if you have a CNAME record defined in the dashboard). Internally within Cloudflare the change is essentially instant.

All of the dns propagation sites i’ve checked shows the old A record. CNAME lookup gives nothing.

And i’m not well adept with nslookup.

There haven’t been A records in domains dns panel in days now.
Still the A records show everywhere while CNAME records can’t be found at all.

As @michael pointed out, a CNAME that’s set to :orange: (proxy) will appear as an “A” record that shows Cloudflare’s reverse proxy IP address.

However, neither hostname (www or the domain) load and show a 522 timeout. If you’ve pointed those records to a new server, it’s possible that it will only work with a CNAME record, so you will need to edit them so they’re :grey: DNS-Only.

1 Like

Thanks for clarification. I got it to work finally. I had switched ssl/tsl mode from flexible to full.
Works fine on flexible.

I was just very baffled because i had numerous other domains that worked with the same s3 hosting/cname combo.

Well. If others have this problem check your ssl/tsl settings.

Thanks guys.

You just made your site insecure by switching the connection to HTTP. Everything from Cloudflare to your site will be now unencrypted.

1 Like

Noted. Fixed it.
Had to do something more than static s3 bucket hosting to get ssl serverside.

Maybe S3 bucket did not have an SSL certificate as “default”?
I remember the Google Cloud Storage in start did not provide SSL certificate, so the only way to server a content via GCS bucket over HTTPS was to have “Flexible SSL” and being :orange: on a CNAME that points to GCS bucket.