CNAME Record Not Resolving at the moment

Hi there

We have just switched to VPS server and it seems our cname is not resolving. I read in a forum that Proxied Cname works as A name so this is normal. But I’d like to make sure you guys also thinking the same thing. Please see the screenshots.

We are using www. for our domain name. But, when we check with leafdns, www fails on every test and nonwww does not. While dnschecker.org fails all versions in Cname but different IP’s


Hi @fatih,

Are you able to share the domain name? Without that, it’s difficult to troubleshoot.

Hi @domjh

Thank you for your reply.

Yes, the site is www.textilegence.com

I keep failing SMTP and SPF. My mails land on Gmail spam. The RDNS is set up fine from server side. Should I set PTR in CF too? We are using mail.xxxx.com

Thank you for your help

Ah, so it’s an email issue. Yes, hostnames for mail services should not be set to :orange:

Hi @sdayman

Thank you for your help. I’ll follow this troubleshooting steps. But first my hosting provider tells me this;

Unfortunately DKIM record is "off’ in Cloudflare and I tried to turn it on, but is not doing it. In this case, you will need to check with Cloudflare directly and find out why the record is off.

In regards to your other question, the emails are still ending on the spam and SMTP is failing due to the lack of authentication records (DKIM) Once you fix the DKIM issue with within Cloudflare, you shouldn’t experience more issues.

I have added the exact DKIM record that is validated in cpanel like;

When I try to validate DKIM

I get the this

The only difference between CF dashboard and Cpanel is TTL times. Cpanel 4 hours and CF 1 day.

How should I proceed?

Your DKIM key has a break in it. One line ends with a “ and the next line begins with a “. Put those lines together and get rid of both “ marks. dmarcian.com is a good place to test these records.

You are right @sdayman. Now it works.

I also found out this here in case anyone having the same problem.
https://forums.cpanel.net/threads/error-in-dkim-core-record.630191/

I have another question.

The server.mydomain.com is no validating the ssl. So I have to use mail.mydomain.com. The hosting compan suggest that I have to install SSL via cloud flare but it is already set FULL.
How do I achieve this?

https://www.sslshopper.com/ssl-checker.html#hostname=server.textilegence.com
https://www.sslshopper.com/ssl-checker.html#hostname=mail.textilegence.com

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.