CNAME record keeps recieving petitions after deleted

Greetings,

I tried to open a ticket but they keep closing it, I once had a CNAME aiming at a digitalocean address.

But then I changed it to an A record to IP. But the server that was binded to the CNAME keeps recieving traffic even a week after it’s deletion.

I cleared all cache, tried developer mode but I don’t know what else to do, Looks like a cloudflare internal issue but no-one is paying attention to it.

Thanks a lot

What’s the record in question?

It’s the same as the old CNAME, they share the same url

And the URL is?

cukies.world

That cannot be a CNAME in the first place, but that host is currently resolving fine to Cloudflare’s proxies.

That’s the main one, I have a CNAME www to cukies.world, this cukies.world is a type A to cukies.world pointing to an IP, but this IP does not recieve traffic. All my other urls from cukies.world resolve correctly to cloudflare proxies.
But the main one www.cukies.world also resolves to cloudflare proxies, I cannot debug this petition to trace where the petition goes because I don’t have it listed to disable it’s proxy.

My infrastructure is:

  • Old server on digitalocean that was registered as a CNAME on cloudflare

  • New IP service wich is registered as an A type to IP on cloudflare

The problem is, I have an A type cukies.work to the new IP that does not recieve the traffic, while the old one keep recieving it constantly. Im afraid that If I shut down the old server traffic will not recieve any traffic at all

Well, that was the very question, what the CNAME is.

Anyhow, there currently is a record for “www” but it’s also proxied, which is why it is an A record and not a CNAME record. Still, it should go to the same address you configured.

If you don’t receive any requests, you might have configured the wrong hostname there. Try pausing Cloudflare and check if your site loads fine then, if it does not you’ll need to adjust your DNS record.

“www” and the naked domain seem to go to the same server, however. What exactly is the issue?

Thanks for your replies,

The issue is, the current configured records are pointing to the new servers and they dont recieve any traffic. For exemple if you tested the url I did not get any request on my new server. Only on the old one that was configured as a CNAME previously.

When you pause Cloudflare, do requests go to the new server?

Can you pause Cloudflare for now and post back when you did so?

By pausing you mean deleting the record?
And yes, I had this record disabled for a week and the website was working anyways

No, pausing. You can do so on the Overview screen at the bottom right.

Thanks!

I paused it and tested the connection from my smartphone and with my linux terminal, It was working anyways.

Also, I just checked the connection and looks like cloudflare proxy is not working properly, it leaks my ip

Looks like pausing cloudflare made connections to access to the new server without ssl, but now that’s running again traffic just goes to the old server again

It’s currently not paused, you need to leave it paused.

Also, if you have SSL issues you should first fix this with your host as otherwise your site cannot be secure.

1 Like

I paused it again, I can’t get it to be for really long becaus ewe have some production services running

All right, your “www” record is just a CNAME record for your naked domain, so that should not really be relevant.

Your domain in general seems to point to an IP address which ends in 163. Is that the new server? However that seems to return the same content as when it was not paused.

Also, yes, you do not have a certificate on your server and an insecure encryption mode on Cloudflare. You need to fix both as well.

Thanks for your help, really appreciate it.

That’s what I don’t understand, I only use cloudflare I dont know where else can I get this domain to aim to that Ip address.

Now that I know it I’ll try to fix it.

Thanks a lot for your help!

Is the mentioned address the new one?