CNAME Record is not updating when proxy turned on

I switched the CNAME record on my domain to a new address, however, it did not work for over 48hours now with the proxy turned on. However, it works correctly and points to the new address when the proxy is turned off. We need the proxy feature for SSL to work with our new host, Netlify.

I tried clearing the cache using Cloudflare’s purge cache tool ( , but it did not work.

The subdomain is:
The old host was Shopify:
The new host is Netlify:

After searching and reading the community posts, I came across the same problem as this one:
When I activate the proxy, the domain points to the old site (When I activate the proxy, the domain points to the old site)

I tried contacting Shopify, as there were suggestions that they use Cloudflare in the backend, to try to remove any configuration related to the subdomain like SSL. However, here’s their response:

  • I took a look into your Domain settings in Shopify Admin > Settings > Domains and was able to confirm that there was no domain connected to your store

  • I also checked in the backend of your store and can confirm that there is no domain or subdomain attached to your store.

  • I also noticed that the subdomain was not a Shopify domain so there are no traces connecting this to Shopify.

  • I also ran a whois check and was able to see that the DNS records do not point to Shopify.

I recommend reaching out to the host provider(ex: Google Domains,GoDaddy etc) of your subdomain and getting their assistance to update the DNS settings.

I’m not sure what to do next, except requesting you to kindly look into the issue and try to clear the configuration from your side. We need to launch our website very soon.

I opened a support ticket but it was closed automatically as I’m not a Pro user.

Thank you for your assistance,

I’m not overtly familiar with Shopify, but when I visit either or in Microsoft Edge, I get what appears to be a Shopify 503 error page.

That should be used after 72 hours you have posted that 11 hours ago , I understand your feeling, But I request you to wait till someone see your post !

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.