CNAME record for a subdomain is not resolve correctly

Hi Guys,

Got a really strange issue here.

The issue for Cloudflare B is that:
b.cloudflare**B**.com cname to **b.awsexample.com** but it actually takes me to **a.awsexample.com**

I am pulling my hairs off cos this strange issue.
Any helps or suggestions will be appreciated.

sorry for the image. I am not allowed to post more than 4 links in the post

Are you able to post screenshots of your Cloudflare relevant pages?

yeah sure. it is from the DNS menu


the academic and admin are working perfectly.
but the booking subdomain is somehow pointing to academic as well.
and the destination domain i cname to is working.

I am not familiar with your AWS application but typically be it an Apache server, or ISS, or a control panel like cPanel then there will be something they may call by the names “vhost” or “ServerName”, “ServerAlias”, or “Accepted Domain”, “Subdomains”, or “Aliases”. Whatever they might call it, more or less its about the same thing to match the incoming requests “Host” header to the respective application internally.

In your AWS portal is there any settings by the names I said above?

1 Like

Greetings,

Thank you for asking.

May I ask what’s the error you are experiencing? :thinking:

Is the sub-domain covered with the SSL certificate?
Before moving to Cloudflare, was your Website working over HTTPS connection?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

I am using route 53 in aws for DNS setting. I am not too sure what u want me to check.
so we the whole thing look likes this
booking cname to booking.xxx.com and in route 53 booking.xxx.com has an A name record points the ipaddress

dont see any errors, just that my cname point to the wrong place
let’s say.
booking cname booking.xxx.com, but it actually points academic.xxx.com

So the CNAME is proxied :orange:, but does it also point to an hostname which is already using Cloudflare maybe?

Have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Maybe, was you sub-domain configured to redirect somewhere else like a “mobile sub-domain”? :thinking:

Please, check for this by navigating to the Speed tab → Optimization → scroll down to the bottom section “Mobile redirect”.

The result was the same?

ssl is working before using cloudfare
current it is on full ssl
the hostname point to is not on Cloudflare it is on route 53(from aws)
i tried access from different devices and different networks, they have the same issues
i dont have the mobile redirection on

thanks guys,
i worked out it is a nginx rule i have to change.

1 Like

Can you please share a screenshot of the relevant NGINX rule you changed? I believe it’s related to the “server_name” I was trying to say before.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.