CNAME record deleted, but it still works

Hi, everyone!

I have a strange bug happening first time in my about three years of good experience with Cloudflare. Let me try to explain it in as much detail as I can.

I have a CMS (actually two, but the behavior (error) is identical) hosted on the Render cloud application platform. Render requires a CNAME record for the instance (site) to work. So far so good, but now I want to move the site to a different VPS server, which requires an A record to work. So I deleted the CNAME record and added an A record, but for some strange reason the CNAME record is still working, but the A record is not – my CMS still has been accessed from Render, not new VPS. And it’s been about two weeks now since I first deleted the CNAME record.

What I have already tried and what didn’t help:

  1. I deleted the A record and added it once more (a couple of times actually).
  2. I checked VPS’s IP address entered in the A record and it’s correct.
  3. I tried to flush Cloudflare’s cache.
  4. I tried to access my CMS from different networks and routers.

What I have tried and what did help “kind of”:

  1. If I turn my newly added A record to “DNS only" (not “Proxied”) mode it instantly starts to work as I need and I can see in logs that Render is not accessed anymore and my new VPS, but then again there’s no use of Cloudflare.
  2. If I switch the record back to “Proxied”, then it goes back to Render again :confused:

Even when I check the Render settings it shows that my DNS configuration is ok (which unfortunately is not what I want right now). The most mysterious thing is that I have no records pointing to Render in my Cloudflare DNS configuration at all, so I have no idea why Cloudflare points to my domain to the old CNAME record when I turn “Proxied” on for my new A record.

Maybe someone can help me to solve this mystery? :slight_smile:

Render use a Cloudflare product known as SSL for SaaS. I’d recommend reading through the following post for more information about this, why it happens, and what you can do to fix it:

If that doesn’t work and Render are unable to remove the old domain Cloudflare configuration - I believe it should be as easy as removing the domain from the “Custom Domains” section within Render, let me know once you’ve submitted a ticket and we can escalate it for you.


Thank you so very much! Removing the domain from Render worked like a charm! :tada: :slight_smile:

And knowing that Render itself uses Cloudflare makes perfect sense why I was experiencing this kind of behavior.

Thank you! :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.