CNAME pointing to Mighty Networks not propagating

I created a CNAME record and it’s not propagating. But it might not have anything to do with cloud flare, here’s the situation:

I host my community on a platform called “Mighty Networks”. I previously used cloudflare to point a cname record to mighty networks on this same root domain and everything worked just fine.

Then we made a change to our community name and so in turn I needed to change the name of the url that my community members login to. (meaning i needed to delete the old cname record and add the new one with the new name)

I did the same process I did last time (created a cname record and pointed it towards mighty networks) but for some reason, mighty networks is rejecting the connection and sending me an error that says: Error Message: Invalid A record pointing to 172.67.143.219. Please correct it to point to 75.2.93.197, 99.83.184.230 instead

I contacted Mighty networks support and sent screen shots of my DNS records, this is how they responded: Tanisha Singh (Mighty Networks)

Jun 15, 2021, 4:51 PM PDT

Hey Michael

I have checked everything on our end with our Domain specialist and you have set up the DNS records correctly. It may be a propagation issue on Cloudflare’s end.

Would you mind reaching out to Cloudflare support to check whether your custom Domain is propagating as intended?

(Cloudflare Help Center)

I tried using “DNS Checker - DNS Propagation Check & DNS Lookup” and it shows that it’s not propagating.

So my question is: Is the cname record not propagating because of something on cloudflares end or is it not propagating because it’s not connected to anything on the other side since Mighty Networks is rejecting my connection?

The record is:
Name - “whywaitlife.4hourdownline.com
Content - “ssl.mn.co

It’s because you have that DNS record :orange: Proxied. Click on the :orange: and toggle it to :grey: and you shouldn’t have a problem.

1 Like

It worked! Thank you!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.