CNAME on subdomain of subdomain not reported after creation

I have created a subdomain CNAME record as required by our hosting provider to undertake verification for CDN setup.

However when we test to confirm that the CNAME has been created it does not report as being there.

The record is setup a DNS only (not proxied), although I have also tried with the proxy setting on.

The record should be:
_44efc768ebd8b7b85a6943eab221e224.summer.loveracing.nz as a CNAME with a target of _[snipped].acm-validations.aws

I cannot understand why this does not work? Does Cloudflare have something that prevents multi level subdomains? Somewhere along the line we have done this same task with success, but I cannot work out how.

Can you confirm that the two Cloudflare name servers at the bottom of your DNS page are Marge and Paul?

If they are, can you please post a screenshot of your DNS record? As a note, for a CNAME like this, it should be set to :grey: DNS Only.

2 Likes


And yes, NS are correct (we’re serving lots of other DNS on the domain via Cloudflare with no issues)

I’ve just noticed that this subdomain seems to have created a txt record… or at least it reports something there.

id 20588
opcode QUERY
rcode NOERROR
flags QR RD RA
;QUESTION
_44efc768ebd8b7b85a6943eab221e224.summer.loveracing.nz. IN TXT
;ANSWER
_44efc768ebd8b7b85a6943eab221e224.summer.loveracing.nz. 2 IN TXT "2a9df7235ac54120bc909a4f3f5b8540"
;AUTHORITY
;ADDITIONAL

To be clear, there is nothing we’ve set for this subdomain of a subdomain other than the CNAME (per above, it’s a completely different target)

That’s certainly interesting. I wonder if that’s what the target returns for a query.

I just asked someone else the same thing for a different situation, but are you on a paid plan and have enabled CNAME Flattening for the entire domain?

1 Like

Yes, CNAME flattening is set across all.

Set it to flatten root only and see if that fixes it. It may take five minutes for DNS to refresh after that.

2 Likes

Thanks. I’ll give that a try and report.

1 Like

The flattening root only setting appears to have done the trick for this!

Thanks massively for your help here @sdayman !

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.