CNAME not working at all

Hi,

I’m trying to add CNAME records for Intercom to my domain, but it doesn’t look like any CNAMEs are actually being added (one record is verified on Intercom, but while doing a DNS lookup, it doesn’t show up).
These are the records I’m trying to add:

Then, when doing a DNS lookup, no CNAME records show up at all: https://dnschecker.org/all-dns-records-of-domain.php?query=astorialighting.com&rtype=ALL&dns=google

What am I missing here? It’s been 3 days since I added the CNAME records, so propagation is not the problem here.

Seems like I can only add one screenshot per post, so here is how the DNS records are added in Cloudflare:

You are asking the tester to look for CNAMEs of astorialighting.com, there isn’t one. DNS can only look up a specific host name, not all those that match “under” it.

You need to ask the tester to look for CNAMEs of outbound.intercom.astorialighting.com and support-email.astorialighting.com.

Aha, thank you! I see I anyway screenshotted the wrong entries as this is the one causing the problems:


And it seems to not be found: https://dnschecker.org/all-dns-records-of-domain.php?query=intercom._domainkey.astorialighting.com&rtype=CNAME&dns=google

Do you know what I can do or if I did something wrong?

This one is giving A records, not a CNAME. Make sure your CNAME for it is set to DNS only and not proxied.

dig intercom._domainkey.astorialighting.com

; <<>> DiG 9.18.19 <<>> intercom._domainkey.astorialighting.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58828
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 3

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
; COOKIE: e78d42b53c5dfd69c01acdfd654dda6b351cffaaa4b1f30e (good)
;; QUESTION SECTION:
;intercom._domainkey.astorialighting.com. IN A

;; ANSWER SECTION:
intercom._domainkey.astorialighting.com. 3523 IN A 76.223.54.146
intercom._domainkey.astorialighting.com. 3523 IN A 13.248.169.48

;; AUTHORITY SECTION:
intercom._domainkey.astorialighting.com. 3523 IN NS ns2.namefind.com.
intercom._domainkey.astorialighting.com. 3523 IN NS ns1.namefind.com.

;; ADDITIONAL SECTION:
ns1.namefind.com.	3484	IN	A	97.74.99.64
ns2.namefind.com.	10904	IN	A	173.201.67.64

;; Query time: 1 msec
;; SERVER: 80.249.96.10#53(80.249.96.10) (UDP)
;; WHEN: Fri Nov 10 07:23:23 UTC 2023
;; MSG SIZE  rcvd: 205

It’s very odd, as you can see from my screenshot the cloud is turned off and it says “DNS Only”. I have the exact same setup on several other sites without any issues. Can you see anything I’m doing wrong?

I really appreciae the help here, thank you!

Have you tried deleting it, waiting a short while, and setting it again?

Yup, several times. But I’ll try it again now!

Tried to remove it and re-add it now, doesn’t seem to make a difference :confused:

Something odd is happening, both _domainkey and intercom._domainkey are showing their nameservers as ns1 and ns2.namefind.com. Have you got any NS records in your DNS for these?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.