CNAME not showing value when orange clouded

I am having an issue with a CNAME record on the domain healthnewsletters.com

The record “links“ is an alias of “cloud1-email-link-tracking.maropost.com”. However, when the proxy is on (orange cloud) the record doesn’t show that value when tested (https://xnnd.com/dns.cgi?t=cname&d=links.healthnewsletters.com). If we gray the record, it shows correctly but the SSL will not work.

Please advise how to fix the issue, so the CNAME returns the value AND the SSL works.

By default, Cloudflare “flattens” CNAMES of the root domain, so it hides what it’s pointing at. I don’t see a way to disable that.

Does this configuration break something on your site?

Yes, it breaks Maropost (an email platform) which requires the CNAME to be set. Is there a way to disable the flatten and make it work like a normal DNS?

Thank you

Change the :orange: to :grey: and install an SSL cert on the origin server bypassing Cloudflare.

In order to provide SSL /CDN/ DDoS cloudflare must proxy the traffic, to do that the DNS record needs to resolve to Cloudflare’s IP, which is what :orange: does. If the provider you’re using for link tracking does support using Cloudflare you’ll need to configure SSL on their server/service.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.